Project

General

Profile

Backport #18397

OSDs commit suicide in rbd suite when testing on btrfs

Added by Nathan Cutler 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Release:
hammer

History

#1 Updated by Nathan Cutler 11 months ago

  • Description updated (diff)

#2 Updated by Nathan Cutler 11 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#3 Updated by Nathan Cutler 11 months ago

description

Symptom: rbd/qemu/{cache/writethrough.yaml cachepool/small.yaml clusters/{fixed-3.yaml openstack.yaml} fs/btrfs.yaml msgr-failures/few.yaml workloads/qemu_xfstests.yaml} fails in hammer - job dies due to OSDs committing suicide.

Hypothesis: failure is btrfs-related and will not be reproducible on XFS.

Solution: backport https://github.com/ceph/ceph/commit/5864d56592ef3ffe765aa1ef0865610dbc7e8725 to hammer.

#4 Updated by Nathan Cutler 11 months ago

  • Status changed from In Progress to Resolved

#5 Updated by Nathan Cutler 11 months ago

  • Target version set to v0.94.10

Also available in: Atom PDF