Project

General

Profile

Bug #18364

rgw: usage stats and quota are not operational for multi-tenant users

Added by Radoslaw Zarzynski 9 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
12/29/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
jewel,kraken
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

$ bin/radosgw-admin user stats --uid 2987047fc47840058e89e6182e0d96c3\$2987047fc47840058e89e6182e0d96c3 --sync-stats --debug_rgw=20
...
2016-12-29 12:59:39.151531 7f0ddb211880 20 reading from default.rgw.data.root:.bucket.meta.cont:67f817f4-9e09-4a2c-9caf-2fdc0eaccbd1.4109.1
2016-12-29 12:59:39.151572 7f0ddb211880 20 get_system_obj_state: rctx=0x7ffdee5d91e0 obj=default.rgw.data.root:.bucket.meta.cont:67f817f4-9e09-4a2c-9caf-2fdc0eaccbd1.4109.1 state=0x7f0de439b0f8 s->prefetch_data=0
2016-12-29 12:59:39.151593 7f0ddb211880 10 cache get: name=default.rgw.data.root+.bucket.meta.cont:67f817f4-9e09-4a2c-9caf-2fdc0eaccbd1.4109.1 : miss
2016-12-29 12:59:39.152968 7f0ddb211880 10 cache put: name=default.rgw.data.root+.bucket.meta.cont:67f817f4-9e09-4a2c-9caf-2fdc0eaccbd1.4109.1 info.flags=0x0
2016-12-29 12:59:39.153054 7f0ddb211880 10 adding default.rgw.data.root+.bucket.meta.cont:67f817f4-9e09-4a2c-9caf-2fdc0eaccbd1.4109.1 to cache LRU end
2016-12-29 12:59:39.153074 7f0ddb211880 20 rgw_get_system_obj() returned =-2
2016-12-29 12:59:39.153089 7f0ddb211880 20 get_bucket_instance_info() returned -2
2016-12-29 12:59:39.153111 7f0ddb211880 20 open_bucket_index() returned -2
2016-12-29 12:59:39.153133 7f0ddb211880 20 cls_bucket_header() returned -2
2016-12-29 12:59:39.153146 7f0ddb211880  0 ERROR: could not sync bucket stats: ret=-2
ERROR: failed to sync user stats: (2) No such file or directory

This is because the name of the RADOS object containing requested bucket instance hasn't been prefixed with the tenant name.

$ bin/rados ls -p default.rgw.data.root
2987047fc47840058e89e6182e0d96c3/cont
.bucket.meta.2987047fc47840058e89e6182e0d96c3:cont:67f817f4-9e09-4a2c-9caf-2fdc0eaccbd1.4109.1

Other subsystems might be affected as well.


Related issues

Related to rgw - Bug #17215: Unable to suspend a user that is part of a tenant Resolved 09/06/2016
Copied to rgw - Backport #18833: jewel: rgw: usage stats and quota are not operational for multi-tenant users Resolved
Copied to rgw - Backport #18843: kraken: rgw: usage stats and quota are not operational for multi-tenant users Resolved

History

#1 Updated by Radoslaw Zarzynski 9 months ago

  • Status changed from New to In Progress

#2 Updated by Radoslaw Zarzynski 9 months ago

cls_user_bucket that is a part of the cls_user_bucket_entry stored on the user buckets lists doesn't have tenant member at all. We're loosing this information.

#3 Updated by Radoslaw Zarzynski 9 months ago

  • Status changed from In Progress to Need Review

#4 Updated by Radoslaw Zarzynski 8 months ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Radoslaw Zarzynski 8 months ago

  • Copied to Backport #18833: jewel: rgw: usage stats and quota are not operational for multi-tenant users added

#6 Updated by Nathan Cutler 8 months ago

  • Backport set to jewel,kraken

#8 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #18843: kraken: rgw: usage stats and quota are not operational for multi-tenant users added

#9 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

#10 Updated by Radoslaw Zarzynski about 2 months ago

  • Related to Bug #17215: Unable to suspend a user that is part of a tenant added

Also available in: Atom PDF