Project

General

Profile

Feature #18235

os/filestore/HashIndex: be loud about splits

Added by Dan van der Ster 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
-
Start date:
12/12/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Reviewed:
User Impact:
Affected Versions:
Release:
Needs Doc:
No

Description

This ML thread "[ceph-users] filestore_split_multiple hardcoded maximum" has coincided with ~1 week of slow requests on one of our clusters. After much debugging we finally tracked it down to filestore splitting.

It would have been much easier to understand the root cause if filestore splitting was verbose. Splitting is a rare but rather important event -- the OSD should be super verbose when it happens. (Otherwise, it simply looks like a filestore write is taking many 10s of seconds, which seems absurd).

So I'm sending this patch for comments. I'm not sure if the dout is needed in the _create function, and I didn't make the merges verbose yet (which I guess is also needed?)

If this makes it to master, I'd appreciate a backport to jewel. (filestore will lose relevance anyway in L and beyond).

PR: https://github.com/ceph/ceph/pull/12421


Related issues

Copied to Ceph - Backport #19183: jewel: os/filestore/HashIndex: be loud about splits Resolved

History

#1 Updated by Nathan Cutler 7 months ago

  • Status changed from New to Need Review

#2 Updated by Nathan Cutler 4 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19183: jewel: os/filestore/HashIndex: be loud about splits added

#4 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF