Project

General

Profile

Bug #17629

ceph_volume_client: TypeError with wrong argument count

Added by Patrick Donnelly over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/20/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
VolumeClient
Labels (FS):
Pull request ID:

Description

From: http://pulpito.ceph.com/pdonnell-2016-10-19_23:26:58-fs:recovery-master---basic-mira/486359/

2016-10-20T00:19:45.564 INFO:teuthology.orchestra.run.mira042.stderr:Traceback (most recent call last):
2016-10-20T00:19:45.564 INFO:teuthology.orchestra.run.mira042.stderr:  File "<string>", line 14, in <module>
2016-10-20T00:19:45.564 INFO:teuthology.orchestra.run.mira042.stderr:  File "/usr/lib/python2.7/dist-packages/ceph_volume_client.py", line 317, in recover
2016-10-20T00:19:45.565 INFO:teuthology.orchestra.run.mira042.stderr:    self._recover_auth_meta(auth_id, auth_meta)
2016-10-20T00:19:45.565 INFO:teuthology.orchestra.run.mira042.stderr:TypeError: _recover_auth_meta() takes exactly 2 arguments (3 given)

The error doesn't make sense to me as the method call appears to have the right number of args:

https://github.com/ceph/ceph/blob/4d9ce9e9a5493cbd0d6485507350b6c7cf5e1d4c/src/pybind/ceph_volume_client.py#L317


Related issues

Duplicates fs - Bug #17216: ceph_volume_client: recovery of partial auth update is broken Resolved 09/06/2016

History

#1 Updated by John Spray over 2 years ago

  • Duplicates Bug #17216: ceph_volume_client: recovery of partial auth update is broken added

#2 Updated by John Spray over 2 years ago

  • Status changed from New to Duplicate

The fix for this just merged in master yesterday.

Python says "2 args, 3 given" because the 3 is counting the "self" arg that's passed to bound member functions.

Also available in: Atom PDF