Project

General

Profile

Bug #16895

src/test: some tests are silencing vstart admin socket setup failures

Added by Patrick Donnelly about 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
08/02/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

The cause of the recent build failures [1] (resolved by [3]) exposed a separate problem in (some) tests where vstart.sh failures were silently ignored. From [2]:

vstarting....DONE
Wait for health_ok...DONE
Created Replicated pool #1
Created Erasure coded pool #2
Creating 4 objects in replicated pool
2016-08-02 12:14:47.716622 7fc0aaed89c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.716702 7fc0aaed89c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.717943 7fc0aaed89c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.717978 7fc0aaed89c0 -1 asok(0x15f1bb0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28037.asok is too long! The maximum length on this system is 107
2016-08-02 12:14:47.739243 7f7bf4c339c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.739335 7f7bf4c339c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.740925 7f7bf4c339c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.740985 7f7bf4c339c0 -1 asok(0x247bba0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28070.asok is too long! The maximum length on this system is 107
2016-08-02 12:14:47.786678 7f77055279c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.786835 7f77055279c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.789932 7f77055279c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.790069 7f77055279c0 -1 asok(0xbe8bb0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28123.asok is too long! The maximum length on this system is 107
created pool rep_pool snap snap1
2016-08-02 12:14:47.931083 7f6f9e96f9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.931383 7f6f9e96f9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.933632 7f6f9e96f9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.933709 7f6f9e96f9c0 -1 asok(0x1542bb0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28345.asok is too long! The maximum length on this system is 107
2016-08-02 12:14:47.959413 7f59299de9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.959523 7f59299de9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.960968 7f59299de9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.961006 7f59299de9c0 -1 asok(0x1251ba0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28375.asok is too long! The maximum length on this system is 107
2016-08-02 12:14:47.992702 7fe3342949c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.992923 7fe3342949c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.994813 7fe3342949c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:47.994904 7fe3342949c0 -1 asok(0xd13bb0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28411.asok is too long! The maximum length on this system is 107
2016-08-02 12:14:48.026351 7fe21eb4f9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.026477 7fe21eb4f9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.028284 7fe21eb4f9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.028348 7fe21eb4f9c0 -1 asok(0x18f6b70) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.28477.asok is too long! The maximum length on this system is 107
Creating 4 objects in erasure coded pool
2016-08-02 12:14:48.753522 7ffb76cac9c0  0 lockdep start
2016-08-02 12:14:48.753538 7ffb76cac9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.753625 7ffb76cac9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.755156 7ffb76cac9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.755206 7ffb76cac9c0 -1 asok(0x1af0bb0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.29216.asok is too long! The maximum length on this system is 107
2016-08-02 12:14:48.860582 7f1e6cbac9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.860835 7f1e6cbac9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.864006 7f1e6cbac9c0 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-08-02 12:14:48.864109 7f1e6cbac9c0 -1 asok(0x23c4bb0) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.29430.asok is too long! The maximum length on this system is 107

On Jenkins, the build path is too long to bind the admin socket. AFAICT, most things still work (tests still pass) but anything which depends on the admin sockets may be working incorrectly.

These failures are not being reported to vstart.sh because the admin socket initialization is not checked for failures [4].

[1] https://github.com/ceph/ceph/pull/10534
[2] https://jenkins.ceph.com/job/ceph-pull-requests/9937/consoleFull#11935013843539e88d-a3cb-4b79-a5cc-3a10dddc28cf
[3] https://github.com/ceph/ceph/pull/10543
[4] https://github.com/ceph/ceph/blob/119f06fcc4ce0e8c5dbe3886af420afe2e244b9e/src/common/ceph_context.cc#L626

History

#1 Updated by Willem Jan Withagen 3 months ago

Currently (2017-07-20) that some problem can be found in:

cephtool-test-mon.sh

Unix Domain socket path too long

The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/build/src/test/td/t-7202/out/client.xx-profile-ro.7107.asok is too long

#2 Updated by Kefu Chai 3 months ago

  • Status changed from New to Resolved
  • Assignee set to Kefu Chai

Also available in: Atom PDF