Project

General

Profile

Bug #16695

radosgw Consumes too much CPU time to synchronize metadata or data between multisite

Added by bajie white over 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
07/15/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
rgw
Release:
jewel
Needs Doc:
No

Description

In the 10.2.0 version, the multisite function is added. I configure two sites int a realm : one is the master zone in the master zonegorup, the other is the master zone in the second zonegroup. Then I start one radosgw for each zone. After I create a user in the master zone, I find the radosgw consume 100% cpu time with the command top.


Related issues

Related to rgw - Bug #15915: rgw command is consuming all the cpu time Resolved 05/17/2016
Related to rgw - Bug #17052: unittest_http_manager times out Resolved 08/17/2016
Copied to rgw - Backport #17343: jewel: radosgw Consumes too much CPU time to synchronize metadata or data between multisite Resolved

History

#1 Updated by bajie white over 1 year ago

I find the problem is the function do_curl_wait. The function call curl_multi_wait in do_curl_wait will be waken because the pipe wait_fd is always readable. I find the wait_fd will never be changed in curl_multi_wait. So the pipe wait_fd will never be read.

If the wait_fd is set O_NONBLOCK when created in RGWHTTPManager::set_threaded and read in do_curl_wait no matter what wait_fd.revents is, the bug can be fixed.

#2 Updated by Casey Bodley over 1 year ago

  • Related to Bug #15915: rgw command is consuming all the cpu time added

#3 Updated by Casey Bodley over 1 year ago

  • Status changed from New to Need Review
  • Assignee set to Casey Bodley

#5 Updated by Casey Bodley over 1 year ago

  • Related to Bug #17052: unittest_http_manager times out added

#6 Updated by Casey Bodley over 1 year ago

  • Backport set to jewel

#7 Updated by Casey Bodley over 1 year ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #17343: jewel: radosgw Consumes too much CPU time to synchronize metadata or data between multisite added

#9 Updated by Nathan Cutler 11 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF