Project

General

Profile

Bug #16663

incorrect value of CINIT_FLAG_DEFER_DROP_PRIVILEGES

Added by Casey Bodley 11 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
07/12/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:

Description

This was causing hangs in test/rgw/test_multi.py, because radosgw is being started via the python subprocess module, which waits for radosgw to terminate or close its stderr. Even though we don't pass CINIT_FLAG_NO_CLOSE_STDERR to global_init(), it still wasn't being closed.

It turns out that CINIT_FLAG_DEFER_DROP_PRIVILEGES has a hex value that overlaps both CINIT_FLAG_NO_DEFAULT_CONFIG_FILE and CINIT_FLAG_NO_CLOSE_STDERR, causing them to be silently enabled when using civetweb.

The fix was merged to master in https://github.com/ceph/ceph/pull/8792


Related issues

Copied to Backport #16667: jewel: incorrect value of CINIT_FLAG_DEFER_DROP_PRIVILEGES Resolved

History

#1 Updated by Nathan Cutler 11 months ago

  • Subject changed from jewel: incorrect value of CINIT_FLAG_DEFER_DROP_PRIVILEGES to incorrect value of CINIT_FLAG_DEFER_DROP_PRIVILEGES
  • Status changed from New to Pending Backport

#2 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #16667: jewel: incorrect value of CINIT_FLAG_DEFER_DROP_PRIVILEGES added

#3 Updated by Loic Dachary 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF