Project

General

Profile

Bug #16443

ceph-deploy mon create-initial command failed with hammer version

Added by min-sheng Lin over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
06/23/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
ceph-deploy
Release:
hammer
Needs Doc:
No

Description

Hi,
I got some problem when running ceph-deploy mon create-initial:

[2016-06-23 08:42:37,995][ceph_deploy.mon][INFO  ] Running gatherkeys...
[2016-06-23 08:42:37,996][ceph_deploy.gatherkeys][INFO  ] Storing keys in temp directory /tmp/tmpDoQGwl
[2016-06-23 08:42:38,010][ceph-mon-1][DEBUG ] connection detected need for sudo
[2016-06-23 08:42:38,023][ceph-mon-1][DEBUG ] connected to host: ceph-mon-1 
[2016-06-23 08:42:38,024][ceph-mon-1][DEBUG ] detect platform information from remote host
[2016-06-23 08:42:38,037][ceph-mon-1][DEBUG ] detect machine type
[2016-06-23 08:42:38,038][ceph-mon-1][DEBUG ] find the location of an executable
[2016-06-23 08:42:38,039][ceph-mon-1][INFO  ] Running command: sudo /sbin/initctl version
[2016-06-23 08:42:38,047][ceph-mon-1][DEBUG ] get remote short hostname
[2016-06-23 08:42:38,048][ceph-mon-1][DEBUG ] fetch remote file
[2016-06-23 08:42:38,049][ceph-mon-1][INFO  ] Running command: sudo /usr/bin/ceph --connect-timeout=25 --cluster=ceph --admin-daemon=/var/run/ceph/ceph-mon.ceph-mon-1.asok mon_status
[2016-06-23 08:42:38,115][ceph-mon-1][INFO  ] Running command: sudo /usr/bin/ceph --connect-timeout=25 --cluster=ceph --name mon. --keyring=/var/lib/ceph/mon/ceph-ceph-mon-1/keyring auth get-or-create client.admin osd allow * mds allow * mon allow *
[2016-06-23 08:42:38,229][ceph-mon-1][ERROR ] "ceph auth get-or-create for keytype admin returned 22
[2016-06-23 08:42:38,230][ceph-mon-1][DEBUG ] Error EINVAL: key for client.admin exists but cap mds does not match
[2016-06-23 08:42:38,434][ceph-mon-2][DEBUG ] connection detected need for sudo
[2016-06-23 08:42:38,631][ceph-mon-2][DEBUG ] connected to host: ceph-mon-2 
[2016-06-23 08:42:38,632][ceph-mon-2][DEBUG ] detect platform information from remote host
[2016-06-23 08:42:38,642][ceph-mon-2][DEBUG ] detect machine type
[2016-06-23 08:42:38,644][ceph-mon-2][DEBUG ] find the location of an executable
[2016-06-23 08:42:38,646][ceph-mon-2][INFO  ] Running command: sudo /sbin/initctl version
[2016-06-23 08:42:38,654][ceph-mon-2][DEBUG ] get remote short hostname
[2016-06-23 08:42:38,655][ceph-mon-2][DEBUG ] fetch remote file
[2016-06-23 08:42:38,657][ceph-mon-2][INFO  ] Running command: sudo /usr/bin/ceph --connect-timeout=25 --cluster=ceph --admin-daemon=/var/run/ceph/ceph-mon.ceph-mon-2.asok mon_status
[2016-06-23 08:42:38,723][ceph-mon-2][INFO  ] Running command: sudo /usr/bin/ceph --connect-timeout=25 --cluster=ceph --name mon. --keyring=/var/lib/ceph/mon/ceph-ceph-mon-2/keyring auth get-or-create client.admin osd allow * mds allow * mon allow *
[2016-06-23 08:42:38,837][ceph-mon-2][ERROR ] "ceph auth get-or-create for keytype admin returned 22
[2016-06-23 08:42:38,838][ceph-mon-2][DEBUG ] Error EINVAL: key for client.admin exists but cap mds does not match
[2016-06-23 08:42:39,036][ceph-mon-3][DEBUG ] connection detected need for sudo
[2016-06-23 08:42:39,234][ceph-mon-3][DEBUG ] connected to host: ceph-mon-3 
[2016-06-23 08:42:39,234][ceph-mon-3][DEBUG ] detect platform information from remote host
[2016-06-23 08:42:39,245][ceph-mon-3][DEBUG ] detect machine type
[2016-06-23 08:42:39,247][ceph-mon-3][DEBUG ] find the location of an executable
[2016-06-23 08:42:39,249][ceph-mon-3][INFO  ] Running command: sudo /sbin/initctl version
[2016-06-23 08:42:39,257][ceph-mon-3][DEBUG ] get remote short hostname
[2016-06-23 08:42:39,258][ceph-mon-3][DEBUG ] fetch remote file
[2016-06-23 08:42:39,260][ceph-mon-3][INFO  ] Running command: sudo /usr/bin/ceph --connect-timeout=25 --cluster=ceph --admin-daemon=/var/run/ceph/ceph-mon.ceph-mon-3.asok mon_status
[2016-06-23 08:42:39,325][ceph-mon-3][INFO  ] Running command: sudo /usr/bin/ceph --connect-timeout=25 --cluster=ceph --name mon. --keyring=/var/lib/ceph/mon/ceph-ceph-mon-3/keyring auth get-or-create client.admin osd allow * mds allow * mon allow *
[2016-06-23 08:42:39,490][ceph-mon-3][ERROR ] "ceph auth get-or-create for keytype admin returned 22
[2016-06-23 08:42:39,490][ceph-mon-3][DEBUG ] Error EINVAL: key for client.admin exists but cap mds does not match
[2016-06-23 08:42:39,492][ceph_deploy.gatherkeys][ERROR ] Failed to connect to host:ceph-mon-1, ceph-mon-2, ceph-mon-3
[2016-06-23 08:42:39,492][ceph_deploy.gatherkeys][INFO  ] Destroy temp directory /tmp/tmpDoQGwl
[2016-06-23 08:42:39,492][ceph_deploy][ERROR ] RuntimeError: Failed to connect any mon

Looks like some problems happened on ceph auth get-or-create command.

ceph-deploy version: 1.5.34
ceph version: 0.94.7

ceph-deploy-ceph.log View (34.6 KB) min-sheng Lin, 06/23/2016 08:57 AM

History

#2 Updated by Eric Chen over 1 year ago

U could change the code on the gatherkeys.py file under the dir /usr/lib/python2.7/site-packages/ceph_deploy

line 78 'mds', 'allow *', change this to 'mds', 'allow', then the create-initial command will be ok.

#3 Updated by Jie ZHU about 1 year ago

Eric Chen wrote:

U could change the code on the gatherkeys.py file under the dir /usr/lib/python2.7/site-packages/ceph_deploy

line 78 'mds', 'allow *', change this to 'mds', 'allow', then the create-initial command will be ok.

it works for me. but why this line should be patched?

Thanks a lot!

#4 Updated by Vasu Kulkarni about 1 year ago

  • Assignee set to Vasu Kulkarni

#5 Updated by Vasu Kulkarni about 1 year ago

  • Assignee changed from Vasu Kulkarni to Alfredo Deza

#7 Updated by Alfredo Deza about 1 year ago

  • Status changed from New to Resolved

Released as part of 1.5.36

Also available in: Atom PDF