Project

General

Profile

Bug #16391

master: build failures with boost > 1.58

Added by Abhishek Lekshmanan about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/20/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Since https://github.com/ceph/ceph/pull/9188 we currently use boost/utility for in_place (rgw_swift), however higher versions of boost no longer include this in utility, we either need to add an additional header or use emplace instead

History

#1 Updated by Abhishek Lekshmanan about 3 years ago

  • Project changed from rgw to Ceph

#2 Updated by Radoslaw Zarzynski about 3 years ago

Is related to: #15925.

#3 Updated by Orit Wasserman about 3 years ago

  • Status changed from New to Pending Backport
  • Backport set to jewel

#4 Updated by Nathan Cutler about 3 years ago

  • Copied to Backport #16392: jewel: rgw: master: build failures with boost > 1.58 added

#6 Updated by Loic Dachary almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF