Project

General

Profile

Bug #16226

rbd-mirror: not propagating deletes for images with snapshots

Added by Jason Dillaman about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
06/10/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

If an image has snapshots, the deletion will first need to purge the snapshots before attempting to remove the image. However, since the image is not primary, it is hitting the following error and aborting:

librbd::journal::StandardPolicy: local image not promoted

Related issues

Copied to rbd - Backport #16231: jewel: rbd-mirror: not propagating deletes for images with snapshots Resolved

History

#1 Updated by Jason Dillaman about 3 years ago

  • Description updated (diff)

#2 Updated by Jason Dillaman about 3 years ago

If refresh is required, the clearing of the journal bit will be refreshed such that journaling is re-enabled. Therefore, you need more than one snapshot on the image to hit this condition.

#3 Updated by Jason Dillaman about 3 years ago

  • Status changed from In Progress to Need Review

#4 Updated by Jason Dillaman about 3 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Jason Dillaman about 3 years ago

  • Copied to Backport #16231: jewel: rbd-mirror: not propagating deletes for images with snapshots added

#6 Updated by Jason Dillaman about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF