Project

General

Profile

Bug #16011

Failure in journal.sh workunit test

Added by Jason Dillaman almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/24/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

+ rbd bench-write testrbdjournal1897 --io-size 4096 --io-threads 1 --io-total 40960 --io-pattern seq
bench-write  io_size 4096 io_threads 1 bytes 40960 pattern sequential
  SEC       OPS   OPS/SEC   BYTES/SEC
elapsed:     0  ops:       10  ops/sec:   426.17  bytes/sec: 1745602.77
++ rbd journal inspect --verbose 10122ae8944a
++ grep -c 'event_type.*AioWrite'
+ local count1=0
+ test 10 -eq 0

With the changes to ensure that the commit position of a new client is initialized to the minimum position of other clients, the 'journal inspect' command returns zero records because the master client has committed all of its entries.


Related issues

Copied to rbd - Backport #16063: jewel: Failure in journal.sh workunit test Resolved

History

#1 Updated by Mykola Golub almost 3 years ago

  • Assignee set to Mykola Golub

#2 Updated by Mykola Golub almost 3 years ago

  • Status changed from New to Need Review

#3 Updated by Jason Dillaman almost 3 years ago

  • Backport set to jewel

#4 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Jason Dillaman almost 3 years ago

  • Copied to Backport #16063: jewel: Failure in journal.sh workunit test added

#6 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF