Project

General

Profile

Bug #15982

Python Librbd API have default value of "features=0", which is causing the Clone operation to Fail

Added by Tanay Ganguly almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/21/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rbd
Pull request ID:

Description

clone(self, p_ioctx, p_name, p_snapname, c_ioctx, c_name, features=0, order=None, stripe_unit=0, stripe_count=0)

Below are the scenario's:
1. If i pass 0, i am seeing an Error ( That's expected because Clone would need layering support )

2. If i pass 1 or 3, its working fine. (Layering, Striping )

3. If i don't pass any value, i.e.rbd_inst.clone(p_ioctx,Image,snap,c_ioctx,Clone_Name)
Then i am seeing an Error, because feature flag have to be there having value, other than 0 ( Default is 0 )

4. If i pass "None", its invalid because it requires an integer.

Jason Analysis:
The bug is that the Python API should default to None for features --
and if None is specified it shouldn't attempt to set the features so
that the defaults can be used.


Related issues

Copied to rbd - Backport #16038: jewel: Python Librbd API have default value of "features=0", which is causing the Clone operation to Fail Resolved

History

#1 Updated by Mykola Golub almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Mykola Golub
  • Backport set to jewel

#2 Updated by Mykola Golub almost 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #16038: jewel: Python Librbd API have default value of "features=0", which is causing the Clone operation to Fail added

#6 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF