Project

General

Profile

Bug #159

cfuse abort on file delete (0.20.2)

Added by Sage Weil almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
05/28/2010
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Associated revisions

Revision 79b39625 (diff)
Added by Greg Farnum almost 9 years ago

ObjectCacher: do not try to deref an invalidated xlist::iterator

Fixes #159

History

#1 Updated by Sage Weil almost 9 years ago

  • Assignee set to Greg Farnum

#2 Updated by Greg Farnum almost 9 years ago

  • Status changed from New to In Progress

#3 Updated by Greg Farnum almost 9 years ago

  • Status changed from In Progress to Resolved

All right, fixed in 0d437a205b4c239cb85f08ad6976868d84bf9ab4.
The ObjectCacher wasn't properly cleaning up objects in a set when there was more than one of them still cached due to an issue with xlist iterators.

Also available in: Atom PDF