Project

General

Profile

Bug #15869

ceph gid mismatch on upgrade from hammer with pre-existing ceph user (SUSE)

Added by Nathan Cutler about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/12/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Scenario: upgrade from hammer to jewel on SUSE, pre-existing ceph user with uid 1000 and gid 100, pre-existing ceph group with gid 1000

Problem: After the upgrade, the "ceph" user's gid (100) does not match the ceph group.

Solution: make the spec file do "usermod -g ceph ceph" if the ceph user already exists (thanks to Sage for suggesting this)

Note: the situation in RH/Fedora is different because the ceph user is created with "useradd ceph -o -g 167" which creates a second ceph user in this case. (That's might be a bug, too?)


Related issues

Related to devops - Bug #15876: rpm installation might result in multiple "ceph" users/groups with different uids/gids existing in the system at the same time New 05/12/2016
Copied to devops - Backport #16107: jewel: ceph gid mismatch on upgrade from hammer with pre-existing ceph user (SUSE) Resolved

History

#1 Updated by Nathan Cutler about 3 years ago

  • Status changed from New to Need Review
  • Backport set to jewel

#2 Updated by Nathan Cutler about 3 years ago

  • Subject changed from ceph gid mismatch on upgrade from hammer with pre-existing ceph user to ceph gid mismatch on upgrade from hammer with pre-existing ceph user (SUSE)

#3 Updated by Nathan Cutler about 3 years ago

Updated the PR to use the Debian semantics (usermod -g ceph unconditionally whether user is created or not)

#4 Updated by Nathan Cutler about 3 years ago

  • Related to Bug #15876: rpm installation might result in multiple "ceph" users/groups with different uids/gids existing in the system at the same time added

#5 Updated by Nathan Cutler about 3 years ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler about 3 years ago

  • Copied to Backport #16107: jewel: ceph gid mismatch on upgrade from hammer with pre-existing ceph user (SUSE) added

#7 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF