Project

General

Profile

Bug #15863

Disabling journaling feature results in "Transport endpoint is not connected" error

Added by Jason Dillaman almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/12/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The journaling feature is successfully disabled but it includes an unwanted error message.


Related issues

Copied to rbd - Backport #15963: jewel: Disabling journaling feature results in "Transport endpoint is not connected" error Resolved

History

#1 Updated by Yuan Zhou almost 3 years ago

I did some quick tests here, looks like the error message is in the watchctx2:
https://github.com/ceph/ceph/blob/master/src/journal/JournalMetadata.cc#L748

Can we just skip this error when print out in handle_watch_error()?

#2 Updated by Jason Dillaman almost 3 years ago

It would be better and cleaner to close the journal before deleting it.

#4 Updated by Mykola Golub almost 3 years ago

  • Status changed from New to Need Review

#5 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #15963: jewel: Disabling journaling feature results in "Transport endpoint is not connected" error added

#7 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF