Project

General

Profile

Bug #15705

ceph status mds output ignores active MDS when there is a standby replay

Added by John Spray almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/03/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

Because standby replay mds_info_t now has rank set for daemons in state standby replay, the by_rank dict in print_summary was getting into a state where the active daemon was ignored and the standby replay daemon was printed instead.


Related issues

Copied to fs - Backport #15968: jewel: ceph status mds output ignores active MDS when there is a standby replay Resolved

History

#1 Updated by John Spray almost 3 years ago

  • Status changed from In Progress to Need Review

#2 Updated by John Spray almost 3 years ago

  • Status changed from Need Review to Pending Backport
  • Backport set to jewel

#3 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #15968: jewel: ceph status mds output ignores active MDS when there is a standby replay added

#4 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF