Project

General

Profile

Bug #15627

install-deps.sh broken on SUSE if systemd-rpm-macros not installed

Added by Nathan Cutler over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/27/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Running install-deps.sh on SLE12-SP1 without systemd-rpm-macros installed results in a very long and strange error, an excerpt from which is:

error: Too many levels of recursion in macro expansion. It is likely caused by recursive macro declaration.
error: line 911:
        test -n "$FIRST_ARG" || FIRST_ARG=$1
        if test "$FIRST_ARG" = "0" ; then
           test -f /etc/sysconfig/services && . /etc/sysconfig/services
           if test "$YAST_IS_RUNNING" != "instsys" -a "$DISABLE_STOP_ON_REMOVAL" != yes ; then
              for service in
error: query of specfile /tmp/install-deps.15991/ceph.spec failed, can't parse
Too few arguments.
At least one package name is required.

The fix is very simple - PR coming.


Related issues

Copied to devops - Backport #15894: jewel: install-deps.sh broken on SUSE if systemd-rpm-macros not installed Resolved

History

#1 Updated by Nathan Cutler over 2 years ago

  • Description updated (diff)

#2 Updated by Nathan Cutler over 2 years ago

  • Status changed from New to Need Review
  • Source changed from other to Community (dev)

#3 Updated by Nathan Cutler over 2 years ago

  • Status changed from Need Review to Pending Backport
  • Backport set to jewel

#4 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #15894: jewel: install-deps.sh broken on SUSE if systemd-rpm-macros not installed added

#5 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF