Project

General

Profile

Bug #15555

s3website: double-error fault not correctly handled

Added by Robin Johnson almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Target version:
-
Start date:
04/20/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
rgw, s3website
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:

Description

AWS S3Website has a behavior for double error handling, and it's not presently working in RGW.

It's intended for the case where ErrorDocument is configured but is 404 or 403 (eg private ACL).

I'm pushing this to low priority, because it's very much an edge case of s3website usage.


Related issues

Related to rgw - Bug #15532: s3website: redirectrule engine broken Resolved 04/16/2016

Associated revisions

Revision fcb3cf16 (diff)
Added by Robin H. Johnson almost 3 years ago

rgw/s3website: Implement ErrorDoc & fix Double-Fault handler

Fix more last minute breakage from merges, now has has a working ErrorDoc as
well as working double-fault. Also moves some s3website-specific code out of
the main S3 codepath.

Fixes: #15532
Fixes: #15555
Signed-off-by: Robin H. Johnson <>

Revision 3c0ac8eb (diff)
Added by Robin H. Johnson almost 3 years ago

rgw/s3website: Implement ErrorDoc & fix Double-Fault handler

Fix more last minute breakage from merges, now has has a working ErrorDoc as
well as working double-fault. Also moves some s3website-specific code out of
the main S3 codepath.

Fixes: #15532
Fixes: #15555
Signed-off-by: Robin H. Johnson <>
(cherry picked from commit fcb3cf169f1fa7cf878eb154dc3f1ff78e278056)

History

#1 Updated by Nathan Cutler almost 3 years ago

  • Backport deleted (jewel)

Removing backport because this issue is resolved by the same PR as #15532

#2 Updated by Nathan Cutler almost 3 years ago

  • Status changed from New to Resolved

#3 Updated by Nathan Cutler almost 3 years ago

  • Related to Bug #15532: s3website: redirectrule engine broken added

Also available in: Atom PDF