Project

General

Profile

Bug #15532

s3website: redirectrule engine broken

Added by Robin Johnson almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
04/16/2016
Due date:
% Done:

0%

Source:
other
Tags:
rgw, s3website, s3website:redirect
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:

Description

Another breakage caused by the NFS/err merge, the entire s3website RedirectRule engine seems to have broken. It was dependent on the error handling path, so the problem probably lies somewhere in there.


Related issues

Related to rgw - Bug #15555: s3website: double-error fault not correctly handled Resolved 04/20/2016

Associated revisions

Revision fcb3cf16 (diff)
Added by Robin H. Johnson over 2 years ago

rgw/s3website: Implement ErrorDoc & fix Double-Fault handler

Fix more last minute breakage from merges, now has has a working ErrorDoc as
well as working double-fault. Also moves some s3website-specific code out of
the main S3 codepath.

Fixes: #15532
Fixes: #15555
Signed-off-by: Robin H. Johnson <>

Revision 3c0ac8eb (diff)
Added by Robin H. Johnson over 2 years ago

rgw/s3website: Implement ErrorDoc & fix Double-Fault handler

Fix more last minute breakage from merges, now has has a working ErrorDoc as
well as working double-fault. Also moves some s3website-specific code out of
the main S3 codepath.

Fixes: #15532
Fixes: #15555
Signed-off-by: Robin H. Johnson <>
(cherry picked from commit fcb3cf169f1fa7cf878eb154dc3f1ff78e278056)

History

#2 Updated by Nathan Cutler over 2 years ago

  • Status changed from New to Need Review
  • Backport set to jewel

#3 Updated by Nathan Cutler over 2 years ago

  • Related to Bug #15555: s3website: double-error fault not correctly handled added

#4 Updated by Nathan Cutler over 2 years ago

  • Status changed from Need Review to Resolved
  • Backport deleted (jewel)

Unflagging jewel backport because the backport is being done in #16182

Also available in: Atom PDF