Project

General

Profile

Feature #15417

Make path prefix ("/volumes") in CephFSVolumeClient configurable

Added by John Spray about 3 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/07/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Reviewed:
Affected Versions:
Component(FS):
Labels (FS):
Manila
Pull request ID:

Description

This would be a convenient way to enable e.g. multiple Manila driver instances ("backends") to use different data pools, by creating "/volumes_hdd" and "/volumes_ssd", setting the proper layouts on those, and then configuring them as prefixes for the different Manila backends.


Related issues

Copied to fs - Backport #15854: jewel: Make path prefix ("/volumes") in CephFSVolumeClient configurable Resolved

Associated revisions

Revision d1a21b07 (diff)
Added by Xiaoxi Chen about 3 years ago

pybind: configurable cephfs_vol_client prefix and ns_prefix.

Which is useful if we would like to have multiple backends
in manila and potentially set different layout based on prefix.

And also make ns_prefix configurable also in order to support
multiple backend.

Fixes #15417

Signed-off-by: Xiaoxi Chen <>

Revision 42f63dc6 (diff)
Added by Xiaoxi Chen about 3 years ago

fs/volume_client: exercise the configurable prefix and ns_prefix.

Also ensure namespace_prefix and vol_prefix are set to default values
if they are not explicitly passed.

Fixes #15417

Signed-off-by: Xiaoxi Chen <>

Revision 5d9ee88e (diff)
Added by Xiaoxi Chen about 3 years ago

pybind: configurable cephfs_vol_client prefix and ns_prefix.

Which is useful if we would like to have multiple backends
in manila and potentially set different layout based on prefix.

And also make ns_prefix configurable also in order to support
multiple backend.

Fixes #15417

Signed-off-by: Xiaoxi Chen <>
(cherry picked from commit d1a21b07ede77ab3f2be7a753426d76de0343086)

Revision e9c3bea4 (diff)
Added by Xiaoxi Chen about 3 years ago

fs/volume_client: exercise the configurable prefix and ns_prefix.

Also ensure namespace_prefix and vol_prefix are set to default values
if they are not explicitly passed.

Fixes #15417

Signed-off-by: Xiaoxi Chen <>
(cherry picked from commit 42f63dc6a6bfbe7667ad2293946fedeb097fabce)

History

#1 Updated by John Spray about 3 years ago

  • Subject changed from Make path prefix in CephFSVolumeClient configurable to Make path prefix ("/volumes") in CephFSVolumeClient configurable

#2 Updated by Ramana Raja about 3 years ago

  • Category set to 87

#3 Updated by Xiaoxi Chen about 3 years ago

  • Status changed from New to Need Review
  • Assignee set to Xiaoxi Chen

#4 Updated by John Spray about 3 years ago

  • Status changed from Need Review to Pending Backport

Merged to master.

Would like to backport this to jewel. Although it's not a bugfix, it's aimed at would-be Manila users who will be targeting Jewel for the forseeable future.

#5 Updated by Nathan Cutler about 3 years ago

  • Backport set to jewel

#6 Updated by Loic Dachary about 3 years ago

  • Copied to Backport #15854: jewel: Make path prefix ("/volumes") in CephFSVolumeClient configurable added

#7 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

#8 Updated by Patrick Donnelly 3 months ago

  • Category deleted (87)
  • Labels (FS) Manila added

Also available in: Atom PDF