Project

General

Profile

Bug #15261

ceph-bluefs-tool segfault

Added by Venky Shankar almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
03/24/2016
Due date:
% Done:

0%

Source:
other
Tags:
bluestore, bluefs
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Executing

  1. ./ceph-bluefs-tool

as it is leads to segfault due to reference to args0. Also, there's less help from the tool of what parameters it expects.

Moreover, there's an assert() failure when checking the return value of buffer::list::write_fd():

int rc = bl.write_fd(fd); 
assert(rc == r);

... write_fd() returns 0 on success.

Associated revisions

Revision ec6f108d (diff)
Added by Venky Shankar almost 3 years ago

os/bluestore: ceph-bluefs-tool fixes

Couple of fixes:
- check vector size before using
- fix assert() failure after write_fd()

Fixes: #15261
Signed-off-by: Venky Shankar <>

History

#1 Updated by Venky Shankar almost 3 years ago

Patch to follow.

#3 Updated by Nathan Cutler almost 3 years ago

  • Status changed from New to Need Review

#4 Updated by Sage Weil almost 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF