Project

General

Profile

Bug #15138

RPM: openldap-devel and openssl-devel do not exist in SLE/openSUSE

Added by Nathan Cutler over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
03/15/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

ceph.spec.in has the following lines https://github.com/ceph/ceph/blob/master/ceph.spec.in#L122-L123

BuildRequires:  openldap-devel
BuildRequires:  openssl-devel

These are not surrounded by any kind of conditional. The SUSE equivalents are openldap2-devel and libopenssl-devel, respectively.


Related issues

Related to devops - Fix #16947: rpm: unify openssl-devel build dependency Rejected 08/07/2016

Associated revisions

Revision 3214ae99 (diff)
Added by Nathan Cutler over 3 years ago

RPM: fix openldap and openssl build dependencies for SUSE

http://tracker.ceph.com/issues/15138 Fixes: #15138

Signed-off-by: Nathan Cutler <>

History

#1 Updated by Nathan Cutler over 3 years ago

  • Status changed from New to In Progress

#2 Updated by Nathan Cutler over 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Need Review to Resolved

#4 Updated by Nathan Cutler almost 3 years ago

  • Related to Fix #16947: rpm: unify openssl-devel build dependency added

Also available in: Atom PDF