Project

General

Profile

Bug #14825

Fix rbd run cli test

Added by Vasu Kulkarni over 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
02/19/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

run cli test will always pass due to exit 0, need to check if the scirpt is outdated and needs a newer or better version

https://github.com/ceph/ceph/blob/master/qa/workunits/rbd/run_cli_tests.sh#L6

#!/bin/bash

wget -q http://download.ceph.com/qa/rbd_cli_tests.pls
wget -q http://download.ceph.com/qa/RbdLib.pm
perl rbd_cli_tests.pls --pool test
exit 0

History

#1 Updated by Zack Cerza over 1 year ago

This is for the workunit script:
https://github.com/ceph/ceph/pull/7781

#2 Updated by Nathan Cutler 10 months ago

There is a suite yaml facet: https://github.com/ceph/ceph/blob/master/qa/suites/rbd/basic/tasks/rbd_cli_tests.yaml

which runs a workunit: https://github.com/ceph/ceph/blob/master/qa/workunits/rbd/run_cli_tests.sh

which downloads a Perl script http://download.ceph.com/qa/rbd_cli_tests.pls [ why .pls ?? ]

which is identical to https://github.com/ceph/ceph/blob/master/qa/qa_scripts/rbd_cli_tests.pl

The workunit also downloads http://download.ceph.com/qa/RbdLib.pm

which is almost exactly the same as https://github.com/ceph/ceph/blob/master/qa/qa_scripts/RbdLib.pm

smithfarm@wilbur:~/src/ceph/SUSE/ceph> diff ~/Downloads/RbdLib.pm qa/qa_scripts/RbdLib.pm 
84,85c84
< our $SNAP_UNPROT_ERR1   = "snap_unprotect: can't unprotect";
< #our $SNAP_UNPROTECT_ERR - bug # 4045  
---
> our $SNAP_UNPROT_ERR1   = "snap_unprotect: snapshot is already unprotected";

(https://github.com/ceph/ceph/pull/1027 explains that change)

Now that qa/ lives in ceph/ceph.git and teuthology clones that repo, the workunit would not have to download anything - it could do something like this:

#!/bin/bash

( cd $(dirname $0)/../../../qa/qa_scripts ; perl rbd_cli_tests.pls --pool test )

( This was inspired by https://github.com/ceph/ceph/commit/cf294777ea92f0911813a7132068584d4f73a65a )

#3 Updated by Nathan Cutler 10 months ago

See #6362 for a higher-level view of the same thing.

#4 Updated by Nathan Cutler 10 months ago

Once the workunit is running the Perl script from qa/qa_scripts, the script itself could be fixed if, as it would appear, it is exiting with status 0 even when there are test failures.

#5 Updated by Nathan Cutler 10 months ago

A run to see how the rbd_cli_tests.yaml behaves in master (wip-18440 and master are equivalent as far as this run is concerned):

teuthology-suite --priority 101 --suite rbd --email ncutler@suse.cz --ceph wip-18440 --machine-type smithi --kernel distro --filter="basic/tasks/rbd_cli_tests.yaml"

pass http://pulpito.front.sepia.ceph.com:80/smithfarm-2017-01-07_22:24:48-rbd-wip-18440-distro-basic-smithi/

The output from run_cli_tests.sh shows that many of the test cases fail:

==========================================================================================
TEST RESULTS
==========================================================================================
==========================================================================================
No. of test cases passed:45
No. of test cases failed:30
==========================================================================================

The numbers of test cases passed and failed vary from test to test.

Since the underlying Perl script always exits with status 0, the CLI test failures do not cause teuthology to report a test failure.

#6 Updated by Vasu Kulkarni 9 months ago

those tests in perl are quite old and never got updated, we will have to rewrite them anyway and include them in qa-suite instead of different url.

#7 Updated by Jason Dillaman 9 months ago

  • Status changed from New to Resolved

#8 Updated by Nathan Cutler 9 months ago

"Fixed" in master by dropping the Perl tests: https://github.com/ceph/ceph/pull/12821

Also available in: Atom PDF