Project

General

Profile

Bug #14756

EC testing plugins are being versioned and installed even though they are only used in "make check"

Added by Nathan Cutler almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/13/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The following shared libraries in src/erasure-code result in the following shared objects that need to be packaged (in the main ceph package) but not versioned:

libec_isa.so
libec_jerasure.so
libec_jerasure_generic.so
libec_jerasure_neon.so
libec_jerasure_sse3.so
libec_jerasure_sse4.so
libec_lrc.so
libec_shec.so
libec_shec_generic.so
libec_shec_neon.so
libec_shec_sse3.so
libec_shec_sse4.so

The plugins in src/test/erasure-code are used in "make check" only. There is no sense in versioning or packaging them:

libec_example.so
libec_fail_to_initialize.so
libec_fail_to_register.so
libec_hangs.so
libec_missing_entry_point.so
libec_missing_version.so
libec_test_jerasure_generic.so
libec_test_jerasure_neon.so
libec_test_jerasure_sse3.so
libec_test_jerasure_sse4.so
libec_test_shec_generic.so
libec_test_shec_neon.so
libec_test_shec_sse3.so
libec_test_shec_sse4.so

Associated revisions

Revision 1b6faf68 (diff)
Added by Nathan Cutler almost 3 years ago

Refrain from versioning EC testing plugins

Since these plugins are only used in "make check", there is no
point in versioning them.

http://tracker.ceph.com/issues/14756 Fixes: #14756

Signed-off-by: Nathan Cutler <>

History

#1 Updated by Nathan Cutler almost 3 years ago

Note that the OBS implements a "devel-file-in-non-devel-package" RPMLINT check that this is tripping. For details on this check, see https://en.opensuse.org/openSUSE:Packaging_checks#devel-file-in-non-devel-package

#2 Updated by Nathan Cutler almost 3 years ago

  • Status changed from New to In Progress

#3 Updated by Nathan Cutler almost 3 years ago

  • Subject changed from Versioned shared libraries in /usr/lib64/ceph/erasure-code have all-zero version numbers to EC testing plugins are being versioned and installed even though they are only used in "make check"
  • Status changed from In Progress to Need Review

#4 Updated by Nathan Cutler almost 3 years ago

  • Description updated (diff)

#5 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF