Project

General

Profile

Bug #14745

osd: call doesn't force promotion from ec base tier

Added by Sage Weil about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
02/12/2016
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

reproduce with:

MON=1 OSD=4 MDS=0 ./vstart.sh  -d -n -x -l -e --cache ec --hitset ec-cache bloom ; ./ceph osd pool set ec-cache min_read_recency_for_promote 4
./rbd -p ec create foo --size 10 --image-format 2 ; ./rbd -p ec info foo ; ./rados -p ec-cache cache-flush rbd_id.foo ; ./rados -p ec-cache cache-evict rbd_id.foo ; ./rbd -p ec info foo

we get EOPNOSUPP.

Associated revisions

Revision 7dbce5ba (diff)
Added by Sage Weil about 3 years ago

osd/ReplicatedPG: respect must_promote in WRITEBACK cache mode

Force a promotion of the op requires it. This bug was easily masked
because the defaultish cache parameters would often promote anyway (e.g.,
if min read recency was 0).

This was broken during the refactor in
1a2689f8d74537b105cdcf2933f080a2bee9f190.

Fixes: #14745
Signed-off-by: Sage Weil <>

History

#2 Updated by Sage Weil about 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF