Project

General

Profile

Bug #14735

ceph-fuse does not mount at boot on Debian Jessie

Added by Florent B over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Administration/Usability
Target version:
-
Start date:
02/11/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
infernalis
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
ceph-fuse
Labels (FS):
Pull request ID:

Description

I have a problem with ceph-fuse on Debian Jessie.

I have this in my fstab :

id=my_user,daemonize=false,mon_host=my_monitor.company.com,keyring=/etc/ceph-keyring.conf,client_mountpoint=/my_directory/
/mnt/cephfs fuse.ceph noatime,_netdev 0 0

"mount /mnt/cephfs" is working fine when I run it.

But on system boot, mount is failing, I can see in systemctl log :

mount340: error parsing '-o': expected string of the form TYPE.ID,
valid types are: auth, mon, osd, mds, client
systemd1: mnt-cephfs.mount mount process exited, code=exited status=1
systemd1: Failed to mount /mnt/cephfs.

"daemonize=false" or "daemonize" is the same.
"id=client.my_user" is the same.

@$ systemctl status mnt-cephfs.mount -l
  • mnt-cephfs.mount - /mnt/cephfs
    Loaded: loaded (/etc/fstab)
    Active: failed (Result: exit-code) since Tue 2016-01-19 12:53:11 CET; 2s ago
    Where: /mnt/cephfs
    What: id=my_user,mon_host=my_monitor.company.com,keyring=/etc/ceph-keyring.conf,client_mountpoint=/my_directory/
    Docs: man:fstab(5)
    man:systemd-fstab-generator(8)
    Process: 1132 ExecMount=/bin/mount -n id=my_user,mon_host=my_monitor.company.com,keyring=/etc/ceph-keyring.conf,client_mountpoint=/my_directory/ /mnt/cephfs -t fuse.ceph -o noatime,defaults,_netdev (code=exited, status=1/FAILURE)

Jan 19 12:53:11 wordpress-dev mount1132: error parsing '-o': expected string of the form TYPE.ID, valid types are: auth, mon, osd, mds, client
Jan 19 12:53:11 wordpress-dev systemd1: mnt-cephfs.mount mount process exited, code=exited status=1
Jan 19 12:53:11 wordpress-dev systemd1: Failed to mount /mnt/cephfs.
Jan 19 12:53:11 wordpress-dev systemd1: Unit mnt-cephfs.mount entered failed state.@

It seems to have an ambiguous problem around -o options and the ones in fstab...


Related issues

Copied to fs - Backport #14761: infernalis: ceph-fuse does not mount at boot on Debian Jessie Rejected

History

#2 Updated by Greg Farnum over 3 years ago

  • Status changed from New to Resolved

#3 Updated by Nathan Cutler over 3 years ago

Should this be backported to Infernalis?

#4 Updated by Florent B over 3 years ago

Nathan Cutler wrote:

Should this be backported to Infernalis?

Yes, please.

#5 Updated by Nathan Cutler over 3 years ago

  • Subject changed from Infernalis: ceph-fuse does not mount at boot on Debian Jessie to ceph-fuse does not mount at boot on Debian Jessie
  • Status changed from Resolved to Pending Backport
  • Backport set to infernalis

#6 Updated by Loic Dachary over 3 years ago

  • Copied to Backport #14761: infernalis: ceph-fuse does not mount at boot on Debian Jessie added

#7 Updated by Florent B over 3 years ago

Is there a reason why this was not backported to Infernalis before 9.2.1 release ?

#8 Updated by Greg Farnum over 3 years ago

  • Priority changed from High to Normal

Bumping down priority as it's just the backport.

#9 Updated by Greg Farnum almost 3 years ago

  • Category changed from 45 to Administration/Usability
  • Status changed from Pending Backport to Resolved
  • Component(FS) ceph-fuse added

I don't think there are likely to be any more infernalis releases now that Jewel is out.

Also available in: Atom PDF