Project

General

Profile

Bug #14723

make check bot broken: execvp: /bin/sh: Argument list too long

Added by Loic Dachary over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
02/10/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

A number of errors similar started happening in the past few days. Noone has been able to reproduce it outside of the Jenkins environment.

https://jenkins.ceph.com/job/ceph-pull-requests/1261/console

.......
PASS: test/osd/osd-scrub-repair.sh
make[5]: execvp: /bin/sh: Argument list too long
make[5]: *** [test-suite.log] Error 127
make[5]: Leaving directory
`/home/jenkins-build/build/workspace/ceph-pull-requests/src'
make[4]: *** [check-TESTS] Error 2
make[4]: Leaving directory
`/home/jenkins-build/build/workspace/ceph-pull-requests/src'
make[3]: *** [check-am] Error 2

Associated revisions

Revision 19391b71 (diff)
Added by Kefu Chai over 3 years ago

Makefile: workaround an automake bug for "make check"

override the automake variable of am__is_gnu_make. it is a workaround
for http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18744. this bug was
fixed in automake 1.15, but automake 1.13 is supported. so we can not
just require 1.15 using `AM_INIT_AUTOMAKE`. this only happens when we
have lots of source files and we are using automake v1.14 or lower.

Fixes: #14723
Signed-off-by: Kefu Chai <>

Revision 9d25202a (diff)
Added by Kefu Chai over 3 years ago

Makefile: workaround an automake bug for "make check"

override the automake variable of am__is_gnu_make. it is a workaround
for http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18744. this bug was
fixed in automake 1.15, but automake 1.13 is supported. so we can not
just require 1.15 using `AM_INIT_AUTOMAKE`. this only happens when we
have lots of source files and we are using automake v1.14 or lower.

Fixes: #14723
Signed-off-by: Kefu Chai <>
(cherry picked from commit 19391b71497555c9bcc37b1e063fd4895df605c5)

Revision 3c5bc079 (diff)
Added by Kefu Chai over 3 years ago

Makefile: workaround an automake bug for "make check"

override the automake variable of am__is_gnu_make. it is a workaround
for http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18744. this bug was
fixed in automake 1.15, but automake 1.13 is supported. so we can not
just require 1.15 using `AM_INIT_AUTOMAKE`. this only happens when we
have lots of source files and we are using automake v1.14 or lower.

Fixes: #14723
Signed-off-by: Kefu Chai <>
(cherry picked from commit 19391b71497555c9bcc37b1e063fd4895df605c5)

Revision 30bddc45 (diff)
Added by Kefu Chai over 3 years ago

Makefile: workaround an automake bug for "make check"

override the automake variable of am__is_gnu_make. it is a workaround
for http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18744. this bug was
fixed in automake 1.15, but automake 1.13 is supported. so we can not
just require 1.15 using `AM_INIT_AUTOMAKE`. this only happens when we
have lots of source files and we are using automake v1.14 or lower.

Fixes: #14723
Signed-off-by: Kefu Chai <>
(cherry picked from commit 19391b71497555c9bcc37b1e063fd4895df605c5)

History

#1 Updated by Loic Dachary over 3 years ago

  • Subject changed from make check bot broken to make check bot broken: execvp: /bin/sh: Argument list too long

#4 Updated by Kefu Chai over 3 years ago

turns out, MAKEFILE_LIST is too long to be passed as a parameter for sh

am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'

and @am__is_gnu_make is evaluated when running

make test-suite.log

evaluation chain:

"make test-suite.log" => am__make_dryrun => am__make_running_with_option => am__is_gnu_make

and it's a known automake bug, reported at http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18744

the bug was fixed in automake 1.15. while centos7 has 1.13.4.

#5 Updated by Kefu Chai over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Kefu Chai

#6 Updated by Kefu Chai over 3 years ago

  • Status changed from In Progress to Need Review

#7 Updated by Kefu Chai over 3 years ago

  • Project changed from sepia to Ceph
  • Source changed from other to Development

#8 Updated by Kefu Chai over 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF