Project

General

Profile

Bug #14609

rados tool does not work with 0 length input (crashes if '--striper' enabled)

Added by Marcel Lauhoff over 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
02/02/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
jewel
Regression:
No
Severity:
4 - irritation
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
jewel
Needs Doc:
No

Description

Command:

./rados --pool=test put toyfile5 <(dd if=/dev/urandom of=- count=4 bs=1M); ./rados --pool=test get toyfile5 >(wc -c)

Output from dd:

4+0 records in
4+0 records out
4194304 bytes (4,2 MB) copied, 0,24987 s, 16,8 MB/s

Output from wc (should be 4M)

0

Command:

./rados --pool=test put --striper toyfile5 <(dd if=/dev/urandom of=- count=10 bs=1M)

Leads to crash (Full trace is attached):

FAILED assert(len > 0)

foo (27.9 KB) Marcel Lauhoff, 02/02/2016 03:27 PM


Related issues

Copied to Ceph - Backport #18815: jewel: rados tool does not work with 0 length input (crashes if '--striper' enabled) Resolved

History

#1 Updated by Marcel Lauhoff over 1 year ago

Sorry, process substitution works. I did something stupid with dd. The only problem is 0 length input:

./rados --pool=test put --striper $RANDOM <(dd if=/dev/urandom count=0 bs=0)

Result: crash

#2 Updated by Sage Weil over 1 year ago

  • Subject changed from rados tool does not work with process substitution (crashes if '--striper' enabled) to rados tool does not work with 0 length input (crashes if '--striper' enabled)
  • Priority changed from Normal to High

#3 Updated by Kefu Chai 8 months ago

  • Status changed from New to In Progress
  • Assignee set to Kefu Chai

being worked on by Shinobu Kinjo

#4 Updated by Kefu Chai 8 months ago

  • Assignee deleted (Kefu Chai)

#5 Updated by Shinobu Kinjo 8 months ago

  • Assignee set to Shinobu Kinjo

#6 Updated by Shinobu Kinjo 8 months ago

  • Release infernalis, jewel added

Reproduced in:
Infernalis: 9.2.1-31-gbaf17c9
Jewel: 10.2.5-5663-g601fb96

#7 Updated by Shinobu Kinjo 8 months ago

  • Status changed from In Progress to Need Review

#8 Updated by Shinobu Kinjo 8 months ago

  • Status changed from Need Review to Testing

#9 Updated by Shinobu Kinjo 8 months ago

  • Status changed from Testing to In Progress

#10 Updated by Shinobu Kinjo 8 months ago

This bug seems to be fixed in master. I'm now trying to find out when it's fixed then back it port to older version(jewel, infernalis(, hammer?))

#11 Updated by Nathan Cutler 8 months ago

@Shinobu: Please note that infernalis has already been retired. We will still backport bugfixes to hammer until the luminous release, but the focus there is on fixing bugs (if any) that prevent users from upgrading to jewel. Knowing that, if you still want to submit a hammer backport for review you are welcome to do so.

#12 Updated by Nathan Cutler 8 months ago

  • Backport set to jewel

#13 Updated by Shinobu Kinjo 8 months ago

@Nathan, Thanks for your suggestion. will follow you.

#15 Updated by Shinobu Kinjo 8 months ago

  • Release deleted (infernalis)

#17 Updated by Nathan Cutler 8 months ago

  • Status changed from In Progress to Pending Backport
  • Assignee deleted (Shinobu Kinjo)

#18 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #18815: jewel: rados tool does not work with 0 length input (crashes if '--striper' enabled) added

#19 Updated by Nathan Cutler 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF