Project

General

Profile

Bug #14535

rbd CLI does not validate pool and snapshot name optionals

Added by Jason Dillaman over 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Target version:
-
Start date:
01/28/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

The "--pool", "--snap", etc optionals are not validated to ensure they don't contain "/" nor "@".

History

#1 Updated by Gaurav Garg 7 months ago

  • Needs Doc set to No

This bug is not reproducible with jewel."--pool" and "--snap" optionals are not validating to ensure they don't contain "/" or "@".

#2 Updated by Jason Dillaman 7 months ago

@Gaurav: the issue is that the "--pool" and "--snap" arguments are not validated but they should be for ops that create images and snapshots (e.g. I shouldn't be able to run "rbd snap create --snap "no@in_snap" image").

#3 Updated by Gaurav Garg 7 months ago

Jason Dillaman wrote:

@Gaurav: the issue is that the "--pool" and "--snap" arguments are not validated but they should be for ops that create images and snapshots (e.g. I shouldn't be able to run "rbd snap create --snap "no@in_snap" image").

Yeah, right. its reproducible with --snap option. i didn't used --snap option while creating snap (i used rbd snap create {pool-name}/{image-name}@{snap-name}). Its a valid issue.

#4 Updated by Gaurav Garg 7 months ago

  • Assignee set to Gaurav Garg

#5 Updated by Gaurav Garg 7 months ago

  • Status changed from New to Need Review

#6 Updated by Jason Dillaman 4 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF