Project

General

Profile

Bug #14534

rgw: cannot limit users to not create buckets

Added by Yehuda Sadeh almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
01/28/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Related issues

Copied to rgw - Backport #16163: jewel: rgw: cannot limit users to not create buckets Resolved

History

#1 Updated by Yehuda Sadeh almost 3 years ago

Currently the max_buckets param on the user info cannot limit users to not be able to create any buckets. Either we add a flag to the user info to allow that, or rework the encoding/decoding of the max_buckets param. I prefer adding a new flag, since the encoding/decoding could be confusing and problematic in multi-zone sync of mixed version.

#2 Updated by Yehuda Sadeh over 2 years ago

  • Status changed from New to Need Review
  • Backport set to jewel

https://github.com/ceph/ceph/pull/9457

In this PR: setting a negative number of buckets prevents the bucket creation (returns permission denied). A zero value to max_buckets is still used for no limit.

#3 Updated by Yehuda Sadeh over 2 years ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #16163: jewel: rgw: cannot limit users to not create buckets added

#5 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF