Project

General

Profile

Bug #14397

disable filestore_xfs_extsize by default

Added by Ken Dreyer about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/18/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Description of problem:
filestore_xfs_extsize defaults to "true" in Hammer. This option is designed to reduce fragmentation on the OSDs.

Tests have found that disabling filestore_xfs_extsize in Hammer improves large sequential write performance by about 20% (Ben Turner's cluster), and in some other tests by lesser amounts. This brings us closer to the large sequential write performance of Firefly.

Steps to Reproduce:
  1. Leave filestore_xfs_extsize unset (currently defaults to "true"),
  2. Run large sequential writes tests via CBT, note performance numbers,
  3. Set filestore_xfs_extsize to "false",
  4. Re-run large sequential writes in CBT, note performance numbers.

Actual results:
The default filestore_xfs_extsize setting results in a large sequential write performance degradation.

Expected results:
The default filestore_xfs_extsize setting should not result in a large sequential write performance degradation.

The proposed fix is to set filestore_xfs_extsize back to "false" in src/common/config_opts.h.

Additional info:
This change comes with a trade-off, because it introduces fragmentation on the OSDs. To address this, we should introduce documentation which explains the fragmentation cost and suggest that users who have a large sequential read use-cases (object storage/CDN) toggle the value to reduce the fragmentation impact over time.


Related issues

Copied to Ceph - Backport #14467: hammer: disable filestore_xfs_extsize by default Resolved

Associated revisions

Revision aed85775 (diff)
Added by Ken Dreyer about 3 years ago

osd: disable filestore_xfs_extsize by default

This option involves a tradeoff: When disabled, fragmentation is worse,
but large sequential writes are faster. When enabled, large sequential
writes are slower, but fragmentation is reduced.

Fixes: #14397

Revision c7252a3d (diff)
Added by Ken Dreyer about 3 years ago

osd: disable filestore_xfs_extsize by default

This option involves a tradeoff: When disabled, fragmentation is worse,
but large sequential writes are faster. When enabled, large sequential
writes are slower, but fragmentation is reduced.

Fixes: #14397
(cherry picked from commit aed85775bf53c273786ce4999320134822722af5)

History

#1 Updated by Ken Dreyer about 3 years ago

  • Backport set to hammer

#2 Updated by Ken Dreyer about 3 years ago

  • Status changed from New to Need Review

#3 Updated by Sage Weil about 3 years ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Loic Dachary about 3 years ago

  • Copied to Backport #14467: hammer: disable filestore_xfs_extsize by default added

#5 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF