Project

General

Profile

Bug #14377

[ FAILED ] LibCephFS.DirLs

Added by Greg Farnum about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
01/14/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
libcephfs
Labels (FS):
Pull request ID:

Description

http://pulpito.ceph.com/gregf-2016-01-12_23:23:33-fs-greg-fs-testing-1-12-1---basic-mira/26500/

This failed the DirLs test and then crashed in the InterProcessLocking and ThreesomeInterProcessLocking tests (we should probably come up with a way to prevent that — probably we can put all the umount calls in a cleanup function which is invoked unconditionally?).

In any case, I suspect it's a race in our master branch rather than a problem with one of the PRs under test there.

Associated revisions

Revision 838b16aa (diff)
Added by Yan, Zheng about 3 years ago

ceph_test_libcephfs: tolerate duplicated entries in readdir

If a dirfrag get fragmented in the middle of readdir, the readdir
result may contain duplicated entries. (but there shouldn't be
any missing entries)

Fixes: #14377
Signed-off-by: Yan, Zheng <>

History

#1 Updated by Greg Farnum about 3 years ago

  • Assignee set to Zheng Yan

Zheng, you've been fixing a lot here lately, please take a look!

#2 Updated by Zheng Yan about 3 years ago

It's caused by duplicated entries in readdir result. This can happen when readdir requires several mds requests and the dirfrag get fragmented in the middle. (when dirfrag gets fragmented in the middle of readdir, we may have duplicated entries, shouldn't not have missing entries)

#3 Updated by Zheng Yan about 3 years ago

  • Status changed from New to Need Review

#4 Updated by Greg Farnum about 3 years ago

  • Status changed from Need Review to Resolved

#5 Updated by Greg Farnum over 2 years ago

  • Component(FS) libcephfs added

Also available in: Atom PDF