Project

General

Profile

Bug #14248

OpTracker needs to release the message throttle in _unregistered

Added by Samuel Just over 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
01/05/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Related issues

Copied to Backport #14323: hammer: OpTracker needs to release the message throttle in _unregistered Resolved

Associated revisions

Revision 67be35cb (diff)
Added by Samuel Just over 1 year ago

OpRequest: release the message throttle when unregistered

We don't want messages in the OpTracker history hanging on to
message throttle.

Fixes: #14248
Backport: hammer, firefly
Signed-off-by: Samuel Just <>

Revision a56b93fa (diff)
Added by Samuel Just 6 months ago

OpRequest: release the message throttle when unregistered

We don't want messages in the OpTracker history hanging on to
message throttle.

Fixes: #14248
Backport: hammer, firefly
Signed-off-by: Samuel Just <>
(cherry picked from commit 67be35cba7c384353b0b6d49284a4ead94c4152e)

Conflicts:
src/msg/Message.h (s/nullptr/0/ because C++98)

History

#1 Updated by Samuel Just over 1 year ago

  • Backport set to hammer, firefly

#2 Updated by Samuel Just over 1 year ago

  • Status changed from New to Pending Backport

#3 Updated by Loic Dachary over 1 year ago

  • Copied to Backport #14322: firefly: OpTracker needs to release the message throttle in _unregistered added

#4 Updated by Loic Dachary over 1 year ago

  • Copied to Backport #14323: hammer: OpTracker needs to release the message throttle in _unregistered added

#5 Updated by Loic Dachary over 1 year ago

Which commit / pull request fixes this issue ?

#6 Updated by Loic Dachary over 1 year ago

  • Backport changed from hammer, firefly to hammer

#7 Updated by Loic Dachary over 1 year ago

  • Copied to deleted (Backport #14322: firefly: OpTracker needs to release the message throttle in _unregistered)

#8 Updated by Loic Dachary over 1 year ago

@sam which commit / pull request fixes this issue ?

#10 Updated by Nathan Cutler 10 months ago

Sam, did you mean https://github.com/ceph/ceph/pull/7148 ? And it should be backported from jewel to hammer?

#11 Updated by Nathan Cutler 5 months ago

  • Status changed from Pending Backport to Resolved
  • Needs Doc set to No

Also available in: Atom PDF