Project

General

Profile

Bug #14233

ceph-disk deactivate does not unmap dmcrypt journal

Added by Loic Dachary over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/05/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

As a result, ceph-disk destroy will fail to zap the corresponding devices because it is still held by devicemapper.

Associated revisions

Revision 756b8e60 (diff)
Added by Loic Dachary over 3 years ago

ceph-disk: deactivate must unmap dmcrypted journal

If the journal is not unmapped, ceph-disk destroy will fail to zap the
corresponding devices because it is still held by devicemapper.

A consequence of this modification is that

ceph-disk activate --dmcrypt --reactivate

no longer works from the command line, because it does not map the
dmcrypted journal. The --reactivate option is added to activate-journal
which will map both the journal and the data devices, if necessary.

http://tracker.ceph.com/issues/14233 Fixes: #14233

Signed-off-by: Loic Dachary <>

History

#1 Updated by Loic Dachary over 3 years ago

  • Status changed from In Progress to Need Review

the ceph-disk: deactivate must unmap dmcrypted journal commit in https://github.com/ceph/ceph/pull/6879

#2 Updated by Loic Dachary over 3 years ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Loic Dachary over 3 years ago

  • Backport set to infernalis

#5 Updated by Loic Dachary over 3 years ago

  • Status changed from Pending Backport to Resolved
  • Backport deleted (infernalis)

Also available in: Atom PDF