Project

General

Profile

Bug #14230

ceph-disk list missing information when dmcrypt

Added by Loic Dachary about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
01/05/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
infernalis
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

/dev/vdb :
 /dev/vdb2 ceph journal (dmcrypt LUKS /dev/dm-0), for /dev/vdb1
 /dev/vdb1 ceph data (dmcrypt LUKS /dev/dm-1)
/dev/vdc :
 /dev/vdc2 ceph journal, for /dev/vdc1
 /dev/vdc1 ceph data, active, cluster ceph, osd.3, journal /dev/vdc2

The /dev/vdb1 should display the same kind of information as /dev/vdc1

This was introduced when ceph-disk list was refactored for infernalis.


Related issues

Copied to Ceph - Backport #14282: infernalis: ceph-disk list missing information when dmcrypt Resolved

Associated revisions

Revision 7aab4ed6 (diff)
Added by Loic Dachary about 3 years ago

ceph-disk: display OSD details when listing dmcrypt devices

The details about a device that mapped via dmcrypt are directly
available. Do not try to fetch them from the device entry describing the
devicemapper entry.

http://tracker.ceph.com/issues/14230 Fixes: #14230

Signed-off-by: Loic Dachary <>

Revision e222d7bc (diff)
Added by Loic Dachary about 3 years ago

ceph-disk: display OSD details when listing dmcrypt devices

The details about a device that mapped via dmcrypt are directly
available. Do not try to fetch them from the device entry describing the
devicemapper entry.

http://tracker.ceph.com/issues/14230 Fixes: #14230

Signed-off-by: Loic Dachary <>
(cherry picked from commit 7aab4ed6f108ddc7bc90300f1999a38f30da3a57)

Conflicts:
src/ceph-disk: an incorrect attempt was made to fix the same
problem. It was not backported and does not
need to be. It is entirely contained in the
code block removed and is the reason for the
conflict.

History

#1 Updated by Loic Dachary about 3 years ago

  • Status changed from Verified to Need Review

the ceph-disk: display OSD details when listing dmcrypt devices commit in https://github.com/ceph/ceph/pull/6879

#2 Updated by Loic Dachary about 3 years ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Loic Dachary about 3 years ago

  • Copied to Backport #14282: infernalis: ceph-disk list missing information when dmcrypt added

#4 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF