Project

General

Profile

Bug #14072

OSD: null pointer access when do handle_osd_map.

Added by xie xingguo over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
12/14/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

We are risking of accessing null pointer of osdmap when OSD try to reconnect and encounters a network error.


Related issues

Copied to Ceph - Backport #15826: OSD: null pointer access when do handle_osd_map. Rejected

Associated revisions

Revision d9144481 (diff)
Added by xie xingguo over 3 years ago

OSD: fix null pointer access and race condition

We are risking of accessing a null osdmap pointer when we failed to handle an osdmap message due to network error.
Also, it is not safe to change failure_pending without protection of hearbeat_lock.

Fixes: #14072
Signed-off-by: xie xingguo <>

History

#1 Updated by Loic Dachary over 3 years ago

Could you please include the snippet of code you believe to be problematic ?

#2 Updated by Loic Dachary over 3 years ago

  • Status changed from New to Need Review

#3 Updated by Sage Weil about 3 years ago

  • Status changed from Need Review to Resolved

#4 Updated by David Zafman almost 3 years ago

  • Status changed from Resolved to Pending Backport
  • Assignee set to David Zafman
  • Backport set to hammer

#5 Updated by David Zafman almost 3 years ago

  • Copied to Backport #15826: OSD: null pointer access when do handle_osd_map. added

#6 Updated by David Zafman almost 3 years ago

  • Status changed from Pending Backport to Resolved

#7 Updated by David Zafman almost 3 years ago

  • Backport deleted (hammer)

Also available in: Atom PDF