Project

General

Profile

Cleanup #13981

configure script doesn't check bzip2-devel presence

Added by Piotr Dalek about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/04/2015
Due date:
% Done:

0%

Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

After cloning git master (state as for 4 Dec 2015), it is not possible to build Ceph from sources when bzip2-devel (or equivalent) package is not installed. This alone is not a problem, only the fact that this requirement is manifested during link-time:

/usr/bin/ld: cannot find -lbz2
collect2: error: ld returned 1 exit status

Bzip2 is required by RocksDB.

Associated revisions

Revision a8b59202 (diff)
Added by Piotr Dałek about 3 years ago

makefiles: remove bz2-dev from dependencies

The only thing that uses bzip2-devel is RocksDB, and it's optional, not
requirement. Drop the bzip2-devel/libbz2-dev dependency entirely, and
let RocksDB use it only if it is already present.

Fixes: #13981
Signed-off-by: Piotr Dałek <>

Revision 911e7a02 (diff)
Added by Kefu Chai about 3 years ago

configure: link against bz2 and lz4 if detected

if we configure --with-librocksdb-static, the rocksdb's Makefile
will detect the installed libbz2 and libz4 by its own. if the
building env happens to have these libraries installed, a link
time dependency is introduced. so we are forced to link against
them.

Fixes: #13850
Fixes: #13981
Signed-off-by: Kefu Chai <>

History

#1 Updated by Piotr Dalek about 3 years ago

  • Status changed from New to Need Review

#2 Updated by Kefu Chai about 3 years ago

  • Status changed from Need Review to Can't reproduce

#4 Updated by Kefu Chai about 3 years ago

  • Tracker changed from Bug to Cleanup
  • Status changed from Can't reproduce to New

#5 Updated by Kefu Chai about 3 years ago

  • Status changed from New to In Progress

#6 Updated by Kefu Chai about 3 years ago

  • Status changed from In Progress to Resolved

#7 Updated by Piotr Dalek about 3 years ago

  • Status changed from Resolved to In Progress

#8 Updated by Kefu Chai about 3 years ago

https://github.com/ceph/ceph/pull/7030 also addresses this issue

#9 Updated by Kefu Chai about 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF