Project

General

Profile

Bug #13858

No way to limit parallelism on low-memory builders

Added by Nathan Cutler about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/23/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

In the openSUSE Build Service, _smp_mflags often gets set to a high number, like -j16 yet the amount of memory available to the build worker is typically no higher than 8GB. This reliably causes the build to fail due to OOM.

Associated revisions

Revision 095c29c3 (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: make --with lowmem_builder limit _smp_mflags

The limit, -j8, may seem arbitrary but works nicely in the openSUSE Build
Service.

http://tracker.ceph.com/issues/13858 Fixes: #13858

Signed-off-by: Nathan Cutler <>

History

#1 Updated by Nathan Cutler about 3 years ago

  • Subject changed from _smp_mflags must be limited to -j8 on openSUSE Build Service to No way to limit parallelism on low-memory builders
  • Status changed from New to In Progress

There is a twist here, because if we put a hard upper limit of -j8 for all SUSE builds, this has a potential adverse affect on SUSE builds happening outside the OBS.

Instead of making the limit conditional upon SUSE, we can use the already existing lowmem_builder bcond to control this.

#3 Updated by Nathan Cutler about 3 years ago

  • Status changed from In Progress to Need Review

#4 Updated by Nathan Cutler about 3 years ago

  • Status changed from Need Review to Resolved
  • Backport deleted (infernalis,hammer)

Also available in: Atom PDF