Project

General

Profile

Bug #13720

librbd: perf counter section name hase empty id

Added by Mykola Golub over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/07/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The expected format for librbd perf counter section name is: librbd-%{id}-%{pool}/name[@%{snap}]. But in generated names id is empty, because perf counters are initialized earlier then id is properly initialized.

Example:

Actual:
% ceph --admin-daemon out/client.admin.7526.asok perf dump
{
"librbd--rbd/testimg26926": {
...
Expected:
% ceph --admin-daemon out/client.admin.7526.asok perf dump |head {
"librbd-3e0d3f18f55b-rbd/testimg26926": {
...

Associated revisions

Revision f33dd766 (diff)
Added by Mykola Golub over 3 years ago

librbd: start perf counters after id is initialized

So the perf counters section name has non-empty id.

Fixes: #13720
Signed-off-by: Mykola Golub <>

History

#2 Updated by Nathan Cutler over 3 years ago

  • Status changed from New to Need Review
  • Source changed from other to Community (dev)

#3 Updated by Jason Dillaman over 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF