Project

General

Profile

Bug #13664

tests: testprofile must be removed before it is re-created

Added by Yuri Weinstein over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
10/31/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
infernalis,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/firefly-hammer-x
Release:
infernalis
Needs Doc:
No


Related issues

Related to Bug #13279: upgrade suite: pool_create failed with error -4 EINTR Duplicate 09/29/2015
Copied to Backport #13672: tests: testprofile must be removed before it is re-created Resolved
Copied to Backport #13671: tests: testprofile must be removed before it is re-created Resolved

Associated revisions

Revision 47abab9a (diff)
Added by Loic Dachary over 1 year ago

tests: destroy testprofile before creating one

The testprofile erasure code profile is destroyed before creating a new
one so that it does not fail when another testprofile erasure code
profile already exists with different parameters.

This must be done when creating erasure coded pools with the C++
interface, in the same way it's done with the C interface.

http://tracker.ceph.com/issues/13664 Fixes: #13664

Signed-off-by: Loic Dachary <>

Revision 30237506 (diff)
Added by Loic Dachary over 1 year ago

tests: destroy testprofile before creating one

The testprofile erasure code profile is destroyed before creating a new
one so that it does not fail when another testprofile erasure code
profile already exists with different parameters.

This must be done when creating erasure coded pools with the C++
interface, in the same way it's done with the C interface.

http://tracker.ceph.com/issues/13664 Fixes: #13664

Signed-off-by: Loic Dachary <>
(cherry picked from commit 47abab9a6f182aa0abe5047c04402850379bcd6d)

Revision a6034294 (diff)
Added by Loic Dachary over 1 year ago

tests: test/librados/test.cc must create profile

Now that the create_one_ec_pool function removes the testprofile each
time it is called, it must create the testprofile erasure code profile
again for the test to use.

http://tracker.ceph.com/issues/13664 Refs: #13664

Signed-off-by: Loic Dachary <>

Revision 5105d50d (diff)
Added by Loic Dachary over 1 year ago

tests: test/librados/test.cc must create profile

Now that the create_one_ec_pool function removes the testprofile each
time it is called, it must create the testprofile erasure code profile
again for the test to use.

http://tracker.ceph.com/issues/13664 Refs: #13664

Signed-off-by: Loic Dachary <>
(cherry picked from commit a60342942b5a42ee04d59af77a6b904ce62eefc4)

Revision 26adf7a3 (diff)
Added by Loic Dachary over 1 year ago

tests: destroy testprofile before creating one

The testprofile erasure code profile is destroyed before creating a new
one so that it does not fail when another testprofile erasure code
profile already exists with different parameters.

This must be done when creating erasure coded pools with the C++
interface, in the same way it's done with the C interface.

http://tracker.ceph.com/issues/13664 Fixes: #13664

Signed-off-by: Loic Dachary <>
(cherry picked from commit 47abab9a6f182aa0abe5047c04402850379bcd6d)

Revision 0eb2ddb0 (diff)
Added by Loic Dachary over 1 year ago

tests: test/librados/test.cc must create profile

Now that the create_one_ec_pool function removes the testprofile each
time it is called, it must create the testprofile erasure code profile
again for the test to use.

http://tracker.ceph.com/issues/13664 Refs: #13664

Signed-off-by: Loic Dachary <>
(cherry picked from commit a60342942b5a42ee04d59af77a6b904ce62eefc4)

History

#1 Updated by Yuri Weinstein over 1 year ago

  • Related to Bug #13279: upgrade suite: pool_create failed with error -4 EINTR added

#2 Updated by Sage Weil over 1 year ago

  • Status changed from New to Verified

2015-10-31 00:11:48.733348 7fd5f9027700 2 mon.a@0(leader) e1 send_reply 0x7fd604837960 0x7fd6046a5200 mon_command_ack([{"prefix": "osd erasure-code-profile set", "name": "testprofile", "profile": [ "k=2", "m=1", "ruleset-failure-domain=osd"]}]=-1 will not override erasure code profile testprofile because the existing profile {directory=/usr/lib/ceph/erasure-code,jerasure-per-chunk-alignment=false,k=2,m=1,plugin=jerasure,ruleset-failure-domain=osd,ruleset-root=default,technique=reed_sol_van,w=8} is different from the proposed profile {jerasure-per-chunk-alignment=false,k=2,m=1,plugin=jerasure,ruleset-failure-domain=osd,ruleset-root=default,technique=reed_sol_van,w=8} v1793) v1

this is a test problem.. it needs to use a different profile than 'testprofile' because the parameters/values have changed.

#3 Updated by Loic Dachary over 1 year ago

  • Status changed from Verified to In Progress
  • Assignee set to Loic Dachary

#4 Updated by Loic Dachary over 1 year ago

  • Status changed from In Progress to Need Review

https://github.com/ceph/ceph/pull/6446 (applies cleanly to firefly)

#5 Updated by Loic Dachary over 1 year ago

  • Backport set to infernalis,hammer,firefly

#6 Updated by Loic Dachary over 1 year ago

  • Subject changed from "[ FAILED ] LibRadosAioEC.MultiWrite*" failed in upgrade:firefly-hammer-x-infernalis-distro-basic-multi to tests: testprofile must be removed before it is re-created

#7 Updated by Loic Dachary over 1 year ago

  • Copied to Backport #13673: tests: testprofile must be removed before it is re-created added

#8 Updated by Loic Dachary over 1 year ago

  • Copied to Backport #13672: tests: testprofile must be removed before it is re-created added

#9 Updated by Loic Dachary over 1 year ago

  • Copied to Backport #13671: tests: testprofile must be removed before it is re-created added

#10 Updated by Loic Dachary over 1 year ago

https://github.com/ceph/ceph/pull/6452 is missing

[----------] 34 tests from LibRadosAioEC
[ RUN      ] LibRadosAioEC.SimpleWrite
test/librados/aio.cc:1881: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-40) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.SimpleWrite (4 ms)
[ RUN      ] LibRadosAioEC.SimpleWritePP
[       OK ] LibRadosAioEC.SimpleWritePP (11477 ms)
[ RUN      ] LibRadosAioEC.WaitForSafe
test/librados/aio.cc:1955: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-43) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.WaitForSafe (6 ms)
[ RUN      ] LibRadosAioEC.WaitForSafePP
[       OK ] LibRadosAioEC.WaitForSafePP (7823 ms)
[ RUN      ] LibRadosAioEC.RoundTrip
test/librados/aio.cc:1990: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-45) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.RoundTrip (5 ms)
[ RUN      ] LibRadosAioEC.RoundTrip2
test/librados/aio.cc:2023: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-46) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.RoundTrip2 (3 ms)
[ RUN      ] LibRadosAioEC.RoundTripPP
[       OK ] LibRadosAioEC.RoundTripPP (10567 ms)
[ RUN      ] LibRadosAioEC.RoundTripPP2
[       OK ] LibRadosAioEC.RoundTripPP2 (11487 ms)
[ RUN      ] LibRadosAioEC.RoundTripPP3
[       OK ] LibRadosAioEC.RoundTripPP3 (6761 ms)
[ RUN      ] LibRadosAioEC.RoundTripSparseReadPP
[       OK ] LibRadosAioEC.RoundTripSparseReadPP (15589 ms)
[ RUN      ] LibRadosAioEC.RoundTripAppend
test/librados/aio.cc:2208: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-51) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.RoundTripAppend (7 ms)
[ RUN      ] LibRadosAioEC.RoundTripAppendPP
[       OK ] LibRadosAioEC.RoundTripAppendPP (11793 ms)
[ RUN      ] LibRadosAioEC.IsComplete
test/librados/aio.cc:2347: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-53) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.IsComplete (4 ms)
[ RUN      ] LibRadosAioEC.IsCompletePP
[       OK ] LibRadosAioEC.IsCompletePP (10235 ms)
[ RUN      ] LibRadosAioEC.IsSafe
test/librados/aio.cc:2430: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-55) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.IsSafe (9 ms)
[ RUN      ] LibRadosAioEC.IsSafePP
[       OK ] LibRadosAioEC.IsSafePP (11478 ms)
[ RUN      ] LibRadosAioEC.ReturnValue
test/librados/aio.cc:2511: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-57) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.ReturnValue (4 ms)
[ RUN      ] LibRadosAioEC.ReturnValuePP
[       OK ] LibRadosAioEC.ReturnValuePP (9771 ms)
[ RUN      ] LibRadosAioEC.Flush
test/librados/aio.cc:2547: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-59) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.Flush (3 ms)
[ RUN      ] LibRadosAioEC.FlushPP
[       OK ] LibRadosAioEC.FlushPP (11877 ms)
[ RUN      ] LibRadosAioEC.FlushAsync
test/librados/aio.cc:2608: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-61) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.FlushAsync (3 ms)
[ RUN      ] LibRadosAioEC.FlushAsyncPP
[       OK ] LibRadosAioEC.FlushAsyncPP (12052 ms)
[ RUN      ] LibRadosAioEC.RoundTripWriteFull
test/librados/aio.cc:2693: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-63) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.RoundTripWriteFull (4 ms)
[ RUN      ] LibRadosAioEC.RoundTripWriteFullPP
[       OK ] LibRadosAioEC.RoundTripWriteFullPP (11628 ms)
[ RUN      ] LibRadosAioEC.RoundTripWriteFullPP2
[       OK ] LibRadosAioEC.RoundTripWriteFullPP2 (8118 ms)
[ RUN      ] LibRadosAioEC.SimpleStat
test/librados/aio.cc:2827: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-66) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.SimpleStat (4 ms)
[ RUN      ] LibRadosAioEC.SimpleStatPP
[       OK ] LibRadosAioEC.SimpleStatPP (12610 ms)
[ RUN      ] LibRadosAioEC.SimpleStatNS
test/librados/aio.cc:2896: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-68) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.SimpleStatNS (3 ms)
[ RUN      ] LibRadosAioEC.SimpleStatPPNS
[       OK ] LibRadosAioEC.SimpleStatPPNS (11236 ms)
[ RUN      ] LibRadosAioEC.StatRemove
test/librados/aio.cc:2994: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-70) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.StatRemove (6 ms)
[ RUN      ] LibRadosAioEC.StatRemovePP
[       OK ] LibRadosAioEC.StatRemovePP (11123 ms)
[ RUN      ] LibRadosAioEC.OmapPP
[       OK ] LibRadosAioEC.OmapPP (8787 ms)
[ RUN      ] LibRadosAioEC.MultiWrite
test/librados/aio.cc:3143: Failure
Value of: test_data.init()
  Actual: "create_one_ec_pool(test-rados-api-fold-21348-73) failed: error rados_mon_command erasure-code-profile set name:testprofile failed with error -22" 
Expected: "" 
[  FAILED  ] LibRadosAioEC.MultiWrite (1553 ms)
[ RUN      ] LibRadosAioEC.MultiWritePP
[       OK ] LibRadosAioEC.MultiWritePP (10960 ms)
[----------] 34 tests from LibRadosAioEC (206990 ms total)

[----------] Global test environment tear-down
[==========] 71 tests from 2 test cases ran. (474963 ms total)
[  PASSED  ] 56 tests.
[  FAILED  ] 15 tests, listed below:
[  FAILED  ] LibRadosAioEC.SimpleWrite
[  FAILED  ] LibRadosAioEC.WaitForSafe
[  FAILED  ] LibRadosAioEC.RoundTrip
[  FAILED  ] LibRadosAioEC.RoundTrip2
[  FAILED  ] LibRadosAioEC.RoundTripAppend
[  FAILED  ] LibRadosAioEC.IsComplete
[  FAILED  ] LibRadosAioEC.IsSafe
[  FAILED  ] LibRadosAioEC.ReturnValue
[  FAILED  ] LibRadosAioEC.Flush
[  FAILED  ] LibRadosAioEC.FlushAsync
[  FAILED  ] LibRadosAioEC.RoundTripWriteFull
[  FAILED  ] LibRadosAioEC.SimpleStat
[  FAILED  ] LibRadosAioEC.SimpleStatNS
[  FAILED  ] LibRadosAioEC.StatRemove
[  FAILED  ] LibRadosAioEC.MultiWrite

15 FAILED TESTS

#11 Updated by Samuel Just over 1 year ago

  • Status changed from Need Review to Pending Backport

#12 Updated by Loic Dachary over 1 year ago

  • Backport changed from infernalis,hammer,firefly to infernalis,hammer

#13 Updated by Loic Dachary about 1 year ago

  • Copied to deleted (Backport #13673: tests: testprofile must be removed before it is re-created)

#14 Updated by Loic Dachary about 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF