Project

General

Profile

Bug #1365

pgmon: cannot guarantee new PGs have correct OSDMap creation epochs

Added by Greg Farnum almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Monitor
Target version:
Start date:
08/05/2011
Due date:
% Done:

0%

Spent time:
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Following on from #1357:
Right now, pools in the OSDMap track their "last_changed" epoch. This is currently set when the pool is created and never changed.
However, pools can get expanded to include more PGs. Currently this doesn't impact the pool's metadata (apart from pg_num) at all. So when the PGMonitor goes through to create the new PGs, it doesn't have a reliable indicator of what epoch they were created in. :(

History

#1 Updated by Greg Farnum almost 8 years ago

  • Status changed from New to In Progress

Solving this by keeping last_changed data member updated the way it's supposed to be.

#2 Updated by Sage Weil almost 8 years ago

  • Target version changed from v0.33 to v0.34

#3 Updated by Sage Weil almost 8 years ago

  • translation missing: en.field_position set to 32

#4 Updated by Greg Farnum almost 8 years ago

  • Status changed from In Progress to Resolved

Done. Also it turns out this won't conflict with snapshot tracking at all; there's a separate snap_epoch for that.

Also available in: Atom PDF