Project

General

Profile

Bug #13642

Objecter: pool op callback may hang forever.

Added by xie xingguo over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
10/29/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
infernalis,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Pool op callback may hang forever due to osdmap update during reply handling.


Related issues

Copied to Ceph - Backport #13770: Objecter: pool op callback may hang forever. Resolved
Copied to Ceph - Backport #13771: Objecter: pool op callback may hang forever. Resolved

Associated revisions

Revision 00c6fa9e (diff)
Added by xie xingguo over 3 years ago

Objecter: pool_op callback may hang forever.

pool_op callback may hang forever due to osdmap update during reply handling.
Fixes: #13642
Signed-off-by: xie xingguo <>

Revision bddbda12 (diff)
Added by xie xingguo over 3 years ago

Objecter: pool_op callback may hang forever.

pool_op callback may hang forever due to osdmap update during reply handling.
Fixes: #13642
Signed-off-by: xie xingguo <>

(cherry picked from commit 00c6fa9e31975a935ed2bb33a099e2b4f02ad7f2)

Revision 2647c20c (diff)
Added by xie xingguo over 3 years ago

Objecter: pool_op callback may hang forever.

pool_op callback may hang forever due to osdmap update during reply handling.
Fixes: #13642
Signed-off-by: xie xingguo <>

(cherry picked from commit 00c6fa9e31975a935ed2bb33a099e2b4f02ad7f2)

History

#1 Updated by Kefu Chai over 3 years ago

  • Status changed from New to Need Review
  • Assignee set to xie xingguo
  • Source changed from other to Community (dev)

#2 Updated by Samuel Just over 3 years ago

  • Assignee changed from xie xingguo to Kefu Chai

#3 Updated by Sage Weil over 3 years ago

  • Status changed from Need Review to Pending Backport
  • Backport set to infernalis,hammer

#4 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #13770: Objecter: pool op callback may hang forever. added

#5 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #13771: Objecter: pool op callback may hang forever. added

#6 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF