Project

General

Profile

Bug #13625

warning: comparison between signed and unsigned

Added by David Zafman almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
10/28/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

Lots of annoying build warnings now on master caused by 0bf2a79e "messages/MOSDOp: fix reqid encoding/decoding"

./messages/MOSDOp.h: In member function ‘osd_reqid_t MOSDOp::get_reqid() const’:
./messages/MOSDOp.h:102:22: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
assert(reqid.inc == client_inc); // decode() should have done this
^
./include/assert.h:144:5: note: in definition of macro ‘assert’
((expr) \
^

Associated revisions

Revision 39fb7f12 (diff)
Added by David Zafman almost 3 years ago

messages/MOSDOp: Cast in assert to eliminate warnings

Fixes: #13625
Caused by 0bf2a79e

Signed-off-by: David Zafman <>

History

#1 Updated by David Zafman almost 3 years ago

  • Status changed from New to Need Review
  • Assignee set to David Zafman

#2 Updated by David Zafman almost 3 years ago

  • Status changed from Need Review to Resolved

39fb7f12cb3a902c3a65c9fe59a00821f3b205a8

Also available in: Atom PDF