Project

General

Profile

Bug #13355

docker-test.sh fails because user root already exists

Added by Nathan Cutler about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
10/03/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

I run the command: test/docker-test.sh --os-type centos --os-version 7 make dist with the unsatisfactory result:

http://paste2.org/EBxZd5UE

Associated revisions

Revision 4698e241 (diff)
Added by Loic Dachary about 3 years ago

tests: allow docker-test.sh to run under root

Do not attempt to create a user if it is root because it already exists.

http://tracker.ceph.com/issues/13355 Fixes: #13355

Signed-off-by: Loic Dachary <>

History

#1 Updated by Loic Dachary about 3 years ago

  • Status changed from New to In Progress

#2 Updated by Loic Dachary about 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Nathan Cutler about 3 years ago

I tried it again using your wip branch. I run the following commands:

# git clone https://github.com/dachary/ceph.git
# cd ceph
# git checkout wip-13355-docker-test
# cd src
# test/docker-test.sh --os-type centos --os-version 7 make check

with the following result (last ~50 lines): http://paste2.org/EtV9YMNm

#4 Updated by Loic Dachary about 3 years ago

test/docker-test.sh --os-type centos --os-version 7 ./run-make-check.sh 

should work.

#5 Updated by Nathan Cutler about 3 years ago

OK, that works. Since that blog post appears to be the only documentation on docker-test.sh, it's better if the examples work "out of the box".

#6 Updated by Loic Dachary about 3 years ago

Right. There also is docker-test.sh --help though

#7 Updated by Loic Dachary about 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF