Project

General

Profile

Bug #12809

hit set clear repops fired in same epoch as map change -- segfault since they fall into the new interval even though the repops are cleared

Added by Samuel Just about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
08/27/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
hammer,firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

ubuntu@teuthology:/ceph/teuthology-archive/samuelj-2015-08-26_12:18:34-rados-wip-sam-testing-distro-basic-multi/1033874

Need to run on_pool_change() after handling the map change event since we may no longer be active!


Related issues

Duplicated by Ceph - Bug #12803: osd: op_commit on cancelled op Duplicate 08/27/2015
Copied to Ceph - Backport #13037: hit set clear repops fired in same epoch as map change -- segfault since they fall into the new interval even though the repops are cleared Resolved
Copied to Ceph - Backport #13038: hit set clear repops fired in same epoch as map change -- segfault since they fall into the new interval even though the repops are cleared Resolved 08/27/2015

History

#1 Updated by Samuel Just about 3 years ago

  • Backport set to hammer,firefly

#2 Updated by Samuel Just about 3 years ago

  • Status changed from New to Testing

#3 Updated by Samuel Just about 3 years ago

  • Assignee deleted (Samuel Just)

https://github.com/ceph/ceph/pull/5707

I'm out of town until 9/14

#4 Updated by Sage Weil about 3 years ago

  • Status changed from Testing to Pending Backport

#5 Updated by Loic Dachary almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF