Project

General

Profile

Bug #12351

ceph.spec.in: useless %py_requires breaks SLE11-SP3 build

Added by Nathan Cutler about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/16/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer,firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

The spec file has the following conditional under the python-rados subpackage:

%if 0%{defined suse_version}
%py_requires
%endif

%py_requires expands to

BuildRequires: /usr/bin/python
PreReq: python = 2.7

The BuildRequires: is already provided, and the PreReq is wrong because
e.g. SLE11-SP3 (a platform we are trying to support) has Python 2.6.


Related issues

Copied to devops - Backport #12447: ceph.spec.in: useless %py_requires breaks SLE11-SP3 build Resolved 07/16/2015
Copied to devops - Backport #12448: ceph.spec.in: useless %py_requires breaks SLE11-SP3 build Resolved 07/16/2015

Associated revisions

Revision cbf6c7b4 (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: drop SUSE-specific %py_requires macro

%py_requires expands to

BuildRequires: /usr/bin/python
PreReq: python = 2.7

The BuildRequires: is already provided, and the PreReq is wrong because
e.g. SLE11-SP3 (a platform we are trying to support) has Python 2.6.

http://tracker.ceph.com/issues/12351 Fixes: #12351

Signed-off-by: Nathan Cutler <>

Revision 601eadbf (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: drop SUSE-specific %py_requires macro

%py_requires expands to

BuildRequires: /usr/bin/python
PreReq: python = 2.7

The BuildRequires: is already provided, and the PreReq is wrong because
e.g. SLE11-SP3 (a platform we are trying to support) has Python 2.6.

http://tracker.ceph.com/issues/12351 Fixes: #12351

Signed-off-by: Nathan Cutler <>
(cherry picked from commit cbf6c7b46b42e163950bf7956e5b7565fca961c9)

Conflicts:
ceph.spec.in
in master, the %py_requires is in the python-rados package,
while in firefly it is in the python-ceph package

Revision a7851933 (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: drop SUSE-specific %py_requires macro

%py_requires expands to

BuildRequires: /usr/bin/python
PreReq: python = 2.7

The BuildRequires: is already provided, and the PreReq is wrong because
e.g. SLE11-SP3 (a platform we are trying to support) has Python 2.6.

http://tracker.ceph.com/issues/12351 Fixes: #12351

Signed-off-by: Nathan Cutler <>
(cherry picked from commit cbf6c7b46b42e163950bf7956e5b7565fca961c9)

History

#1 Updated by Nathan Cutler about 3 years ago

  • Status changed from New to In Progress

#2 Updated by Nathan Cutler about 3 years ago

  • Status changed from In Progress to Pending Backport

#3 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF