Project

General

Profile

Bug #12301

ceph.spec.in running fdupes unnecessarily

Added by Nathan Cutler about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/13/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer,firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

In openSUSE there is a policy to use %fdupes in the spec file if RPMLINT
complains about duplicate files wasting space in the filesystem.

However, RPMLINT is not so complaining, so drop fdupes.


Related issues

Copied to devops - Backport #12304: ceph.spec.in running fdupes unnecessarily Resolved 07/13/2015
Copied to devops - Backport #12305: ceph.spec.in running fdupes unnecessarily Resolved

Associated revisions

Revision 53072b90 (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: do not run fdupes, even on SLE/openSUSE

In openSUSE there is a policy to use %fdupes in the spec file if RPMLINT
complains about duplicate files wasting space in the filesystem.

However, RPMLINT is not so complaining, so drop fdupes.

http://tracker.ceph.com/issues/12301 Fixes: #12301

Signed-off-by: Nathan Cutler <>

Revision cdde626f (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: do not run fdupes, even on SLE/openSUSE

In openSUSE there is a policy to use %fdupes in the spec file if RPMLINT
complains about duplicate files wasting space in the filesystem.

However, RPMLINT is not so complaining, so drop fdupes.

http://tracker.ceph.com/issues/12301 Fixes: #12301

Signed-off-by: Nathan Cutler <>
(cherry picked from commit 53072b9019caf72e0313b2804ea174237ed7da33)

Revision bd25136d (diff)
Added by Nathan Cutler about 3 years ago

ceph.spec.in: do not run fdupes, even on SLE/openSUSE

In openSUSE there is a policy to use %fdupes in the spec file if RPMLINT
complains about duplicate files wasting space in the filesystem.

However, RPMLINT is not so complaining, so drop fdupes.

http://tracker.ceph.com/issues/12301 Fixes: #12301

Signed-off-by: Nathan Cutler <>
(cherry picked from commit 53072b9019caf72e0313b2804ea174237ed7da33)

History

#1 Updated by Nathan Cutler about 3 years ago

  • Status changed from New to In Progress

#2 Updated by Nathan Cutler about 3 years ago

  • Status changed from In Progress to Pending Backport

#3 Updated by Nathan Cutler about 3 years ago

  • Backport changed from hammer to hammer,firefly

#4 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF