Project

General

Profile

Bug #11955

/sbin/mkcephfs is not packaged on Firefly / CentOS 6

Added by Ken Dreyer over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/10/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

https://github.com/ceph/ceph/commit/efbca0465c2946e113771966df08cf7cf37b1196 added mkcephfs to the files listing, but this path is only correct for CentOS 7. In CentOS 6, it's installed to /sbin/mkcephfs instead.

This causes rpmbuild to fail to build the tip of the firefly branch on EL6.


Related issues

Related to devops - Bug #11922: Missing "ceph-release-1-0.el6.noarch.rpm" in upgrade:firefly-firefly-distro-basic-vps run Won't Fix 06/08/2015

Associated revisions

Revision 7f1abd90 (diff)
Added by Ken Dreyer over 3 years ago

ceph.spec.in: package mkcephfs on EL6

Commit efbca0465c2946e113771966df08cf7cf37b1196 added mkcephfs to the
RPM %files listing, but this /usr/sbin path is only correct for CentOS
7. In CentOS 6, the utility is present at /sbin/mkcephfs instead. This
causes rpmbuild to fail to build the tip of the firefly branch on EL6.

Adjust the RPM %files list so we properly package mkcephfs on both EL7
and EL6.

http://tracker.ceph.com/issues/11955 Refs: #11955

Signed-off-by: Ken Dreyer <>

History

#1 Updated by Ken Dreyer over 3 years ago

  • Status changed from In Progress to Need Review

Firefly PR: https://github.com/ceph/ceph/pull/4924

Please note that this issue only affects Firefly, because mkcephfs is not present in Hammer and above.

#2 Updated by Yuri Weinstein over 3 years ago

Is this related to #11922 ?

#3 Updated by Ken Dreyer over 3 years ago

Yuri Weinstein wrote:

Is this related to #11922 ?

Quite possibly! I was wondering why the CentOS 6 gitbuilder didn't catch this until now :) Maybe it did, and I didn't know where to look.

#4 Updated by Ken Dreyer over 3 years ago

  • Status changed from Need Review to Resolved

Sage has merged the above PR just now, so this fix will be in the next Firefly release, v0.80.10.

#5 Updated by Ken Dreyer over 3 years ago

To clarify - this fix is not needed in Hammer, master, or anywhere else. Just firefly.

#6 Updated by Loic Dachary over 3 years ago

  • Release set to firefly

Also available in: Atom PDF