Project

General

Profile

Feature #11766

rbd-mirror: basic structure

Added by Josh Durgin about 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
01/19/2016
Due date:
% Done:

100%

Source:
other
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:


Subtasks

Subtask #14412: Track epoch and period for mirrored imagesResolvedJason Dillaman

Subtask #14413: Pull full image from remote peer when out-of-syncResolvedJason Dillaman

Subtask #14414: Add new "exclusive lock released" journal event to librbdClosed

Subtask #14415: Pull journal events from remote peer to local journalResolved

Subtask #14417: Interlock RBD mirroring daemon and acquiring exclusive lockResolved

Subtask #14419: RBD mirroring settings should be moved to new pool objectResolvedJosh Durgin

Subtask #14420: New RBD notification pool object for recording mirroring errorsResolved

Subtask #14421: Propagate image deletes from remote pool to local poolResolvedRicardo Dias

Subtask #14530: Journal close should be non-blockingResolvedJason Dillaman

Subtask #14663: Integrate librbd with journal tag allocationResolvedJason Dillaman

Subtask #14673: Asynchronously open and close image replayersResolved

Subtask #14739: Support deleting a journal when its being replayed by the RBD mirroring daemonCan't reproduce

Subtask #14869: journal library should re-use thread pool and timerResolvedJason Dillaman

Subtask #14937: Cloned images must only be bootstrapped after parent image successfully syncResolvedJason Dillaman

Subtask #14981: rbd-mirror daemon systemd / upstart scriptsResolvedJason Dillaman

Subtask #15029: Use watch/notify to alert to specific changes in the rbd_mirroring objectResolvedJason Dillaman

Subtask #15108: Periodically update the sync point object number during syncResolvedRicardo Dias

Subtask #15109: Integrate image sync process within rbd-mirror image replayerResolvedJason Dillaman

Subtask #15110: Image sync should sync full snapshot stateResolvedJason Dillaman

Subtask #15142: Integrate the rbd mirroring directory within the replay daemonResolvedRicardo Dias

Subtask #15232: Support failover / failbackResolvedJason Dillaman

Subtask #15238: Switch fsid over to mirror uuidResolvedRicardo Dias

Subtask #15239: Throttle in-flight image syncs to only a X concurrentResolvedRicardo Dias

Subtask #15670: Delete image when a resync is requestedResolvedRicardo Dias

Subtask #15710: The exclusive lock policy should support skipping the journalClosed

Subtask #15718: rbd-mirror admin socket commands to start/stop/restartResolved

History

#1 Updated by Josh Durgin about 4 years ago

  • Target version set to v9.0.4

#2 Updated by Josh Durgin about 4 years ago

  • Assignee set to Josh Durgin

#3 Updated by Josh Durgin almost 4 years ago

  • Target version changed from v9.0.4 to v10.0.1

#4 Updated by Josh Durgin over 3 years ago

  • Target version changed from v10.0.1 to 10.0.2

#5 Updated by Jason Dillaman over 3 years ago

  • Description updated (diff)

#6 Updated by Josh Durgin over 3 years ago

  • Description updated (diff)

#7 Updated by Jason Dillaman almost 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF