Project

General

Profile

Bug #11686

RGW init script needs to check /var/lib/ceph/radosgw

Added by Ken Dreyer about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/20/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

In order to support ceph-deploy's new RGW functionality, the RGW init script needs to check /var/lib/ceph/radosgw.

There is a PR that does this, https://github.com/ceph/ceph/pull/4606 , which was merged to master. This needs to be cherry-picked to hammer.


Related issues

Copied to devops - Backport #11735: RGW init script needs to check /var/lib/ceph/radosgw Resolved 05/20/2015

History

#1 Updated by Ken Dreyer about 3 years ago

  • Status changed from New to Pending Backport

Note that there was another change on master, https://github.com/ceph/ceph/pull/4056 , corresponding to ticket #11140, which makes the cherry-picks conflict.

Note that #11140 is not currently marked for backporting to hammer. Do we want to backport the change for #11140 to hammer also?

#2 Updated by Loic Dachary about 3 years ago

  • Assignee set to Sage Weil

(setting sage as an assignee because he is the author of the original patches, not because an action is required of him)

#3 Updated by Loic Dachary almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF